Visio "Save as web page"

Discussion in 'Visio Archive' started by TDM, Jan 9, 2006.

  1. TDM

    TDM Guest

    I have to admit up front, I am fishing a bit trying this NG
    so no flames please.

    I have a visio drawing with 3 pages. I do a
    File/Save as Web Page, all goes well.

    I can use IE, Netscape, or FireFox to view this web
    page no problem on my local file system.

    If I put the visio output on a "real" web
    server, IE loads the page, but displays
    no graphics, then, IE chokes with the
    "Send/Dont Send" errror report. I have
    tried this on 3 systems with the same
    results. Same consistent results every time.

    However, Netscape and FireFox loads and displays
    just fine, even when the files are on a real
    web server.

    My version of Visio is 2003, nothing special. Any
    ideas as to why this would happen ? I am inclined
    to believe there may be a "timing" issue. I ran these
    files on my local Linux box running Apache and there
    was no problem. But once the files were on an Internet
    web server, it choked.

    Thanks in advance.

    TDM
    TDM, Jan 9, 2006
    #1
    1. Advertising

  2. The Save As Web feature actually publishes two different versions of the web
    page -- a full featured version for recent versions of IE and a downlevel
    version for other browsers. With the new Windows XP SP2 security features,
    the downlevel version is also shown if the file is on the local machine.

    Based on your description, it sounds like your browser is having problems
    with the full featured version. To get around this, you can click on the
    "Publish" button in the save as dialog, then uncheck the "Publishing
    Options" like details and Pan and Zoom. Turning off these features should
    stop the crashing.

    Of course, this crashing should not happen at all. If you'd be willing, I'd
    be interested in seeing a copy of your diagram to try to diagnose what is
    causing the issue.

    --
    Bill Morein
    Office Graphics - Visio
    Microsoft Corporation
    http://blogs.msdn.com/wmorein

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "TDM" <> wrote in message
    news:...
    >
    > I have to admit up front, I am fishing a bit trying this NG
    > so no flames please.
    >
    > I have a visio drawing with 3 pages. I do a
    > File/Save as Web Page, all goes well.
    >
    > I can use IE, Netscape, or FireFox to view this web
    > page no problem on my local file system.
    >
    > If I put the visio output on a "real" web
    > server, IE loads the page, but displays
    > no graphics, then, IE chokes with the
    > "Send/Dont Send" errror report. I have
    > tried this on 3 systems with the same
    > results. Same consistent results every time.
    >
    > However, Netscape and FireFox loads and displays
    > just fine, even when the files are on a real
    > web server.
    >
    > My version of Visio is 2003, nothing special. Any
    > ideas as to why this would happen ? I am inclined
    > to believe there may be a "timing" issue. I ran these
    > files on my local Linux box running Apache and there
    > was no problem. But once the files were on an Internet
    > web server, it choked.
    >
    > Thanks in advance.
    >
    > TDM
    >
    Bill Morein [MSFT], Jan 12, 2006
    #2
    1. Advertising

  3. TDM

    TDM Guest

    "Bill Morein [MSFT]" <> wrote in message
    news:...

    Bill,

    Thanks for your input. My version of IE is
    the latest that I am aware of, and I also
    had 2 other systems try, but I am not sure
    of the verison there. I believe one of them
    to be the latest as well, but not completely sure.

    The pan and zoom, along with the "Custom Properties"
    frame work as they should, you just dont get the image.
    If you move your mouse over the blank image, the
    "Custom properties" change as they should. I tested
    the zoom in the short time I have before IE crashes,
    and I got no errors so I assumed it worked, yet hard
    to tell when you cant see the image.

    New data, I just tested on my work system, and
    NO CRASH ! The image does not appear at first,
    but after about 15 seconds, it finally shows up. I
    am guessing that the image would eventually show up
    on the 3 systems I tested, if IE did not crash so soon.

    IE version here at work is :

    6.0.2900.2180.xpsp_sp2_gdr.0503011519CO

    I am sending the link to your e-mail, I dont want
    to post here.

    At your liesure of course. My real intent was to
    use the "Save as Web page" output in Microsoft
    "HTML Help workshop" for project I am working
    on, and I have that working fine.

    I posted the output to a web page
    to get the customers feedback without a personal
    visit, so getting it working would be nice,
    but not a show stopper.

    TDM
    TDM, Jan 17, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. stuart street
    Replies:
    0
    Views:
    146
    stuart street
    Mar 4, 2006
  2. cc.shine

    Visio 2003 Save As Web Page

    cc.shine, May 16, 2005, in forum: Visio Developers
    Replies:
    1
    Views:
    101
    Dick Hamilton [MSFT]
    May 20, 2005
  3. Bart
    Replies:
    2
    Views:
    57
    Scott
    May 14, 2007
  4. Kevin Bowden
    Replies:
    0
    Views:
    84
    Kevin Bowden
    Jun 30, 2004
  5. Gary
    Replies:
    1
    Views:
    95
    Cindy M -WordMVP-
    Jul 28, 2006
Loading...

Share This Page