Word 2007 Form fields duplicate when updated/refreshed


T

ToddC

For this problem to occur, a document must be protected for forms and Track
Changes turned ON in “Final†display mode. Any {REF bookmark} form field
that is in the document will duplicate itself when the form fields are
refreshed. A refresh will occur when: printing, print previewing, right
clicking on the field and selecting update, or via a refresh command in a vba
script. Once Refreshed, the text of the form field will duplicate, causing
repeated text in the document.

This problem is intermittent, meaning that I can create a new document (via
the procedure outlined below) and sometimes the problem will occur and
sometimes it will not. Once a document has this problem, it will not go
away.

This problem seems similar to the problem outlined in KB119867, but that
article does not specify word 2007 as having this problem.

Steps to recreate problem:
1. Create a new blank document
2. Type the text: This is a test
3. Select the text from step 2
4. Select Insert tab from ribbon bar
5. Select bookmark from Links section
6. Enter TEST for the bookmark name and then press the ADD button
7. Position the cursor below the bookmarked text
8. Select Quckparts from the TEXT section
9. Select field…
10. Shoose Ref from the field names list
11. Choose TEST from the bield properties bookmark name:
12. Click the OK button.
13. Select the Review tab from the ribbon bar.
14. Select the Track Changes from the tracking section
15. Change the revision to Final
16. Select Protect document from the protect section.
17. In the restrict formatting section, #2 editing restrictions chek the box
“allow only this type editing in the document†and choose “Filling in formsâ€
from the dropdown directly below it.
18. In the restrict formatting section, #3 Start enforcement, press the
“Yes, start enforcing protection†button.
19. Click ok when prompted for a password.
20. Right click on the form field and select “update fieldâ€
21. Again, right click on the form field and select “update fieldâ€. You
will now see the duplicate problem.


Any help or suggestions is greatly appreciated!
 
Ad

Advertisements

T

ToddC

I just discoved that the problem is 100% repeatable if you turn protection
off, modify text in the bookmark and then turn protection back on. I have
modified the steps to recreate the problem accordingly. Help is desperately
needed....

1. Create a new blank document
2. Type the text: This is a test
3. Select the text from step 2
4. Select Insert tab from ribbon bar
5. Select bookmark from Links section
6. Enter TEST for the bookmark name and then press the ADD button
7. Position the cursor below the bookmarked text
8. Select Quickparts from the TEXT section
9. Select field…
10. Choose Ref from the field names list
11. Choose TEST from the field properties bookmark name:
12. Click the OK button.
13. Select the Review tab from the ribbon bar.
14. Select the Track Changes from the tracking section
15. Change the revision to Final
16. Select Protect document from the protect section.
17. In the restrict formatting section, #2 editing restrictions check the
box “allow only this type editing in the document†and choose “Filling in
forms†from the dropdown directly below it.
18. In the restrict formatting section, #3 Start enforcement, press the
“Yes, start enforcing protection†button.
19. Click ok when prompted for a password.
20. Right click on the form field and select “update fieldâ€
21. Again, right click on the form field and select “update fieldâ€. Note
that the field does not update.
22. Turn the document protection off
23. Change the text contained within the book mark to “This is a test 2â€
24. Turn the document protection on
25. Again, right click on the form field and select “update fieldâ€. Now
note that the form field has duplicated itself.
 
G

Graham Mayor

Check the calculate on exit check box of the form field to update the REF
field on exit.
The REF field will reproduce whatever is in the bookmark. If you want it to
reproduce only the content of the form field, use the bookmark name from the
field properties.

--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP


<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 
T

ToddC

Perhaps my terminology was wrong... The text of the Ref field duplicating is
my problem. It occurs when the bookmarked text is changed, track changes is
on in Final mode, and form protection is on. In my documents I have
multiple bookmarks enclosing database fields and I use the REF to display the
results in various places in the document.

The workaround that I have come up with is to override the updatefields,
fileprint, fileprintpreview routines to turn off protection before they
execute then turn it back on afterward. By doing this, the protection isn't
on when the form fields update, so the problem doesn't occur.

One remaining problem that I have is that I cannot get this to work in the
"View Full Screen", "View Options", "Show Printed Page". I thought that
overriding the fileprintpreviewfullscreen would work, but that doesn't appear
to be the routine that is called.
 
Ad

Advertisements

G

Graham Mayor

The duplication is caused by having Track Changes selected. That is
incompatible with form filling.
Unlock the form, turn off track changes and re-lock the form. Update the
fields and the duplicates will go.
--
<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
Graham Mayor - Word MVP


<>>< ><<> ><<> <>>< ><<> <>>< <>><<>
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top