Access 2010 Disable Microsoft Access Security Notic

Discussion in 'Access General' started by Leslie Coover, Aug 10, 2013.

  1. I have two hyperlink fields on a form. My hyperlinks are to docx files in the same folder that the Access 2010 database is in. When I click on a hyperlink I get the annoying message:

    Microsoft Access Security Notice
    A potential security concern has been identified.
    This locaion may be unsafe.
    Name of file.docx
    Hyperlinks can be harmful to your computer and data. To protect your computer, click only those hyperlinks from trusted sources. Do you want to continue?

    I made made my folders and subfolders trusted, and made documents trusted, etc. Everything I tried on File→Options→Trust Center→Trust Center Settings. . . has not worked. Perhaps there is something in the hyperlink field box properties that I can change. Any help appreciated.

    Leslie Charles
     
    Leslie Coover, Aug 10, 2013
    #1
    1. Advertisements

  2. Update: Using Data Type = Attachment seems to work better

    • Operating System: Windows 7 Professional (64 bit). Home use—NOT on anetwork
    • Processor Speed = 2GHz
    • Up-to-date security software installed
    • Microsoft Office Professional Plus 2010

    Access Trust Center Settings:
    • Trusted Publishers = none
    • Trusted Locations = folders and subfolders on my computer
    • Add-ins = nothing selected
    • ActiveX Settings = Enable all controls without restrictions and without prompting
    • Macro Settings = Enable all macros
    • DEP Settings = nothing selected
    • Message Bar = Show the Message Bar in all applications . . .
    • Privacy Options = none selected

    All of these options probably don’t need turned off, but since I am NOT working on a network, and I have updated security software, I concluded theyprobably aren’t needed.

    Using the Attachment Data Type for a new field, I inserted it into my main form, and then set its Display As property to Paperclip. This allowed me to enter numerous links to documents, spreadsheets, and different graphics application files using just one (MS Access form) field. When nothing is linked, the paperclip icon shows (0), for one link: (1), for two: (2), for three: (3), etc. Double-clicking the icon lets me see the complete list of attachments. And when I choose a file to open there is no Security Warning.

    The only potential drawback is: hypertext links cannot be assigned; at least that was my experience. I use Firefox and when I attempted to open my Internet browser to define a hypertext link I got the following error message:

    The attachment’C:program Files (x86)\Mozilla Firefox\firefox.exe’ has been determined to be unsafe, and the operation has been cancelled.

    To create hypertext links on my form I used Data Type = Hyperlink fields (one field per hyperlink). These links open nicely without any Security Warning message.

    Leslie Charles
     
    Leslie Coover, Aug 15, 2013
    #2
    1. Advertisements

  3. Forget the previous--it doesn't work. When I saved an opened file that I thought was linked my changes were not updated. I went back to 3 OLE fields, setting the property to "Clip" and skipping the Icon rig-a-ma-role let mesee at least a portion of the file name in the OLE field on my form.

    Leslie Charles
     
    Leslie Coover, Aug 18, 2013
    #3
  4. Leslie Coover

    Gloops Guest

    Leslie Coover wrote, on 19th Aug. 2013 00:12 UTC + 2 :
    Hello,

    Did you have an in-depth look at the Access options ?
    Is there a safety tab in there ?
     
    Gloops, Aug 18, 2013
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.