Cannot join on memo, OLE or Hyperlink Object


S

Steve Marsh

Join query against two linked SQL tables returning the
error "Cannot join on memo, OLE or Hyperlink Objects".
None of the columns in either table are memo or hyperlink.

Any comments regarding what might be the source of the
problem would be greatly appreciated.

Steve Marsh
 
Ad

Advertisements

M

Michel Walsh

Hi,

That just that, a memo or a large binary object cannot be used in a
join, or as a group, or as distinct, it is by design.


Hoping it may help,
Vanderghast, Access MVP
 
Ad

Advertisements

Joined
Oct 8, 2013
Messages
1
Reaction score
0
I recently upgraded from Access 2010 to 2013 and received this error when I tried to run a query between a brand new database and an old database. After a lot of checking on the web where I couldn't find an answer that worked, I figured it out. When I updated, Access 13 turned all my fields into short fields but kept the old long field lengths of 255 characters. The short fields in the new database either did not set a character length or set it at 50. Once I changed those to 255, my query's worked. Hope this helps others who, like me, only have a working knowledge of access.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top