Can't add calendar exceptions for resources (vacations, etc.) in 2


C

Chris in San Diego

Resources managers (and the resources) need to add vacation times, etc. to
their calendars. When I go to "Change Working Time..." for a resource I
can't edit the fields in the Exceptions tab, regardless of how I get there
(from resource sheet, resource information, tools/change working time...).

I found documentation that says a "specific permission" is needed
(http://office.microsoft.com/en-us/project/HA012242991033.aspx), but it
doesn't say *what* permission. Resource Managers have "Manage Enterprise
Calendars" permission set, but still can't add exceptions for their resources.

How do I make the exception fields writeable for resource owners so they can
enter vacations? And will this apply to the individual resources too, or is
there another method for them to enter their own vacations?

We're using Project Server 2007.

Thanks,
Chris
 
D

Dale Howard [MVP]

Chris --

Are you and your Resource Managers opening the Enterprise Resource Pool and
checking out the resources for editing using Project Professional 2007? If
so, the default permissions in the system allow the Project Server
administrators and members of the Resource Managers group to edit the
calendars for their resources. There are no specific permissions that
Resource Managers need to edit resource calendars; they already possess the
necessary permissions if your Project Server administrator HAS NOT edited
the default permissions in the Resource Managers group.

Regarding every other user, people can add nonworking time to their own
personal calendars in the Enterprise Resource Pool by using the Plan
Administrative Time feature from the My Timesheets page. Hope this helps.
 
Ad

Advertisements

C

Chris in San Diego

Hi Dale,

Yes, I found your post "Enterprise Resource Calendars" from 6/6/2007 2:15 PM
PST and followed the directions. Checking out the Enterprise Resource Pool
and opening the specific user did not enable us to enter exception times in
their calendar.

I actually did edit the permissions for the Resource Owners goup to
explicitly allow "Manage Enterprise Calendars" to Global Permissions since it
was not set. (Should it be?)

I have read that users need to use the Timesheet feature to enter their own
time off. We're not yet using Timesheets, so for now their managers will
have to maintain their calendars.

Next steps?

Thanks for your help,

Chris
 
D

Dale Howard [MVP]

Chris --

Is the resource manager in question included in any other security Groups in
PWA? If so, remove him from all other Groups. Beyond this, have you done
any other edits to either the Resource Managers group or the My Resources
category? If so, what did you change?

Finally, NO, you do NOT need to select the Manage Enterprise Calendars
permission. That permission allows a user to open and edit enterprise
calendars such as the enterprise Standard calendar. Let us know the answers
to my questions above and we will try to help.
 
C

Chris in San Diego

Hi Dale,

Yes, our resource managers are also project managers and sometimes belong to
other groups. I removed him from all other groups but Resource Manager and
Project Manager (because he is one), but it didn't help. There are no Denies
set in either of these groups.

The My Resources category has only Resources Managers in "Users and groups
with permissions" and the permissions match the Resources Manager template.
Under Projects it has "All current and future projects in Project Server
database" and under Resources it has "All current and future resources in
Project Server database" with none of the boxes below checked. (It did have
"They are descendants of the User via RBS" checked, but I removed that to see
if it would make a difference. It didn't. I've left it unchecked for now.)

There are similar settings on the My Projects category: Project Managers is
the only group; permissions set with Project Manager template; all current
and future projects; all current and future resources; no checked boxes.

We still can't type anything in the exceptions field. :-(

I have removed Manage Enterprise Calendars from Resource Managers.

Thanks for your continued assistance,

Chris
 
D

Dale Howard [MVP]

Chris in San Diego --

Ah, the plot thickens. OK, let me confirm how you are trying to edit the
resource calendars. Ask your resource manager to try these EXACT steps and
let us know the results:

1. Log into PWA and then navigate to the Resource Center page.
2. Select the option checkbox for at least one resource.
3. Click the Open... button.

The system should launch Microsoft Project 2007, log the resource manager
into Project Server, open the Enterprise Resource Pool, and check out the
selected resources for editing.

4. Double-click the name of one of the resources in the checked out
Enterprise Resource Pool.
5. In the Resource Information dialog, click the Change Working Time
button.
6. In the calendar grid at the top of the Change Working time dialog,
select at least one day for scheduled nonworking time, such as a personal
day, for example.
7. In the Exceptions grid at the bottom of the dialog, enter the name of
the nonworking time and then press the Enter key.

At this point, does the system allow the resource manager to enter
nonworking time in the Exceptions grid? Please let us know and we will try
to help.
 
C

Chris in San Diego

Hi Dale,

We've been trying it a bit differently:

1. In Project Pro, open a project that includes the resource whose calendar
we want to edit
2. In Project Pro, click Tools/Enterprise Options/Open Enterprise Resource
Pool...
3. Select the resource (now in a PWA-looking screen) and click Edit Details
(the assumption being that this "checks out" the resource - perhaps wrong)
4. In Project Pro, select View Resource Sheet

Continue starting with your step 4 below.

When I try your step 3, I get a message from PWA (pop up window) that says:

"Microsoft Office Project Server Professional 2007 is required for this
action. Ensure that your copy of Project Professional 2007 can connect to
this server. If both of these conditions are true and you still get this
message, contact your system administrator for assistance."

Both of the conditions are true, and, sadly, I'm the system administrator.
I don't know why Project Pro doesn't open.

Thanks,

Chris
 
C

Chris in San Diego

Update: I had the resource manager try your steps, and it worked! He was
able to add a vacation week. At first his schedule didn't change, but he
closed and reopened the schedule and then the resource's tasks were moved
around the vacation time. Success!

On the other hand, I'm still having the problem in my last post.

It's unfortunate (and very confusing) that Project lets the user get to the
Change Working Time screen many ways - that don't work. It would be good if
the button were grayed out for all but The Correct Way, or better yet if
clicking on the button provided instructions for The Correct Way if the user
accessed the screen via an incorrect way.

Thanks for clearing up the mystery. Now if you can help figure out why it
doesn't work for me... :)

Chris
 
D

Dale Howard [MVP]

Chris --

Your steps are basically all wrong, which is why you are having problems.
First of all, when you need to add vacation time to a resource's calendar in
the Enterprise Resource Pool, DO NOT open any projects. Instead, open the
Enterprise Resource Pool and check out the resources using the steps I have
detailed. And DO NOT click the Edit Details button in the Resource Center
page either. Select the resources in the Resource Center page and then
click the Open button. Beyond this, make sure that the URL for PWA is
exactly the same as the URL you entered in your Project Server login account
in Microsoft Project 2007. Hope this helps.
 
Ad

Advertisements

D

Dale Howard [MVP]

Chris --

It suddenly dawned on me late yesterday afternoon that maybe your RM wasn't
following the correct steps. Be sure to stress to your RM that he should
not open any enterprise projects before opening the Enterprise Resource Pool
and editing resource calendars. The process is the other way around. Open
the pool and edit the resources, then open the projects as needed to see the
new working schedule. Hope this helps.
 
C

Chris in San Diego

Hi Dale,

Thanks for solving that for us. Any idea why when I click "Open..." on the
Resource Center page I get:
"Microsoft Office Project Server Professional 2007 is required for this
action. Ensure that your copy of Project Professional 2007 can connect to
this server. If both of these conditions are true and you still get this
message, contact your system administrator for assistance."
I can't figure this out.

Thanks,

Chris
 
D

Dale Howard [MVP]

Chris --

Did you verify that the URL in your Project Server login account in
Microsoft Project is IDENTICAL to the URL used to access PWA? That is
usually the cause of the error. Let us know.
 
C

Chris in San Diego

Hi Dale,

Yes, it's identical. I can bring up Project Pro, select the server profile,
click OK and connect to Project Server. The only glitch I have is that I
frequently have to clear out my cache or it wants to open my projects
read-only. Other than that, I have no trouble connecting.

But when PWA tries to open Project, it fails. I've found it's not just from
trying to edit a global resource. The same thing happens when I try to edit
one of my projects from PWA.

(This is really a different topic, and I wonder if I should open - or search
for - another thread. Thoughts?)

Thanks,
Chris
 
C

Chris in San Diego

PS. I am a member of the Project Managers group, and it does have "Log on to
Project Server from Project Professional" set.
 
D

Dale Howard [MVP]

Chris --

Since this is a different issue, would you consider posting it as a new
question in this newsgroup? That would allow others to see your question
and share their ideas with you. Otherwise, I'm kind of out of ideas for
you. Hope this helps.
 
Ad

Advertisements

C

Chad

I tested this and the key permission is a category permission "Edit Enterprise Resource Data". If you want PM's to be able to edit all resource calendars then set this for the My Organization category for their group. Otherwise use a My Projects or My Resources category depending on who's calendar you want them to edit. Since editing calendars needs to be done in Project Pro, this is the minimum permissions needed.
Category: Edit Enterprise Resource Data, View Enterprise Resource Data
Global: Log On, Log on to Project Server from Project Professional, View Resource Center

The steps would be to go to PWA, Resource Center, check the box for the resource to edit, click Open. This will launch Project Pro (must have a server profile set up). Then doubleclick the resource name and click Change Working Time and make the calendar edits. Click Save and exit Project Pro.
Resources managers (and the resources) need to add vacation times, etc. to
their calendars. When I go to "Change Working Time..." for a resource I
cannot edit the fields in the Exceptions tab, regardless of how I get there
(from resource sheet, resource information, tools/change working time...).

I found documentation that says a "specific permission" is needed
(http://office.microsoft.com/en-us/project/HA012242991033.aspx), but it
does not say *what* permission. Resource Managers have "Manage Enterprise
Calendars" permission set, but still cannot add exceptions for their resources.

How do I make the exception fields writeable for resource owners so they can
enter vacations? And will this apply to the individual resources too, or is
there another method for them to enter their own vacations?

We're using Project Server 2007.

Thanks,
Chris
On Tuesday, February 16, 2010 7:22 PM Dale Howard [MVP] wrote:
Chris --

Are you and your Resource Managers opening the Enterprise Resource Pool and
checking out the resources for editing using Project Professional 2007? If
so, the default permissions in the system allow the Project Server
administrators and members of the Resource Managers group to edit the
calendars for their resources. There are no specific permissions that
Resource Managers need to edit resource calendars; they already possess the
necessary permissions if your Project Server administrator HAS NOT edited
the default permissions in the Resource Managers group.

Regarding every other user, people can add nonworking time to their own
personal calendars in the Enterprise Resource Pool by using the Plan
Administrative Time feature from the My Timesheets page. Hope this helps.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top