Currency symbol showing after the number


C

cesarabs

Version: 2008
Operating System: Mac OS X 10.5 (Leopard)
Processor: Intel

No matter what currency symbol I choose from the Mac OSX System Preferences/International/Formats/Currency the symbol always shows after the number (10$) instead of in front of it ($10). I live in Mexico so I thought it might be a problem with my region's format, but if I choose any other region (for expample the US or Japan) it still shows the symbol after the number (10US$ or 10¥). I know I can change this manually in the currency format inside of Excel, but it would save me a lot of time if there was a way to have the symbol in front of the number as a default. Is there any way I can change this? Thanks in advance.
 
Ad

Advertisements

C

CyberTaz

Have you checked The International - Formats preferences at the bottom to
make sure Currency is set correctly? Is the correct Input Method set in the
Input Menu page of that same International dialog?

As another thought, are both OS X [10.5.7] & Office [12.1.9] fully updated?

Regards |:>)
Bob Jones
[MVP] Office:Mac
 
C

cesarabs

Thanks a lot for your prompt reply Bob, I have checked both, at the bottom of international - formats preferences the currency is set to pesos mexicanos and the input Method is set to Español ISO. Actually in the formats tab under "numbers" the format is showing correctly, ($1,234.56). Even if I change this settings to US and US dollars and change the input method to US English the currency symbol keeps showing after the number in Excel.
OSX is updated to 10.5.7 and I just finished updating Office to 12.1.9 hoping this issue would have been addressed, but no luck, the symbol keeps showing after the number, any other suggestions? Thanks again.
 
C

CyberTaz

Well, this is a bit perplexing ‹ at least for me :-} It sound as though all
the settings are correct & the updates are in place. AFAIK, however, this
isn't an issue experienced by others & I can't reproduce it here. I have a
feeling that it must be local to your system, but it's a matter of figuring
out what...

Hold the Shift key while you launch Excel & see if the problem continues.

Also, run Excel in a different User Account to see if you have the same
issue there.

You might also try logging in to your normal user account while holding the
Shift key to see if that makes a difference.

Reply with your results & I'll make some inquiries in the mean while.

Regards |:>)
Bob Jones
[MVP] Office:Mac
 
C

cesarabs

Thanks Bob, I once again did everything you suggested , I tried running Excel with a different user, tried holding shift while logging in with my user and the new one I created and while launching Excel, but again the currency sign appeared after the number. And I found out that my parents' copy of Office 2008 has the same problem, it is installed in an iMac and is the same I installed in my macbook with a different key, I didn't ask them to log in with a different user but it also runs the updated version of Leopard and the region format is set correctly , so I was wondering if this could be a faulty Office 2008 copy (which doesn't sound possible as I have updated it), or is it just that the version sold in Mexico has this flaw.

Regards,

Cesar
 
C

CyberTaz

I'm afraid I still have no reply to the inquiry I sent in so there's nothing
new to suggest. For clarification, is your copy of Office an English version
or a Spanish version? If English, I doubt that it's any different than an
English version sold anywhere else.

What specific format is applied... Format> Cells - Currency? Currency Style
using the toolbar button? What happens if you actually type the $ along with
a value? Does this happen in new files as well as existing files? If only in
certain files were they created elsewhere? Anything else you can think of
might help figure this out.

Regards |:>)
Bob Jones
[MVP] Office:Mac
 
Ad

Advertisements

P

Pat McMillan

Hi Cesar,

I checked this with the English version of Office 2008 on a system with the
regional Number format set to Mexican Pesos and when I enter "1234" in a
cell and then set the format in Excel to "Currency" the value in the cell
displays as "MEX$1,234.00". It sounds like this is what you're expecting?

If you follow the same steps can you tell me exactly what is displayed in
the cell? Is it "1,234.00MEX$"?

Also, can you tell me what localized version of Office you are running? Can
I assume it is Spanish (that is, all menus and dialog strings are in
Spanish)? I can look at a Spanish version next.

It would help if you could send your reply both to the list and to me
directly at (e-mail address removed) in case I don't get a chance to check the
list for a few days.

Thanks,

Pat
 
C

CyberTaz

Thanks for dropping by, Pat :) Using the plain vanilla English version I
haven't been able to repro anything like this, so I'm at a loss.

Regards |:>)
Bob Jones
[MVP] Office:Mac
 
Ad

Advertisements

C

cesarabs

Sorry for taking this long to answer Bob, I was out for a while and thought there wasn't any follow up to my problem. Thanks Pat, when I follow the exact same steps the number displayed in the cell is 1,234.56$, not 1,234.56MEX$. When I manually choose from the cell format currency option $-Mexico it is displayed correctly ($1,234.56) but if i choose the option MXN-peso mexicano, the symbol is displayed after the number (1,234.56MXN). The problem I have is that the default currency symbol is set to appear after the number. I wouldn't mind if the currency symbol would appear without the letters (MXN), I just want it to appear before the number ($1,234.56) as a default.
I'm running the spanish version of Office (all menus are in spanish), so it would be great if you could look at it and see if the same happens to you. Thanks again to both of you.

Regards,

Cesar
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top