Database Not Opening


S

Sean Timmons

So, I have what is admittedly a vey large DB (Near 2 GB).

I attempted to add a table (200 MB) to the DB, and the Database errored on me.

I ran a compact and repair, which appeared to be running along fine, then my
database window suddenly disappeared.

When I attempt to open, it just hourglasses for a split second and shows a
blank database screen. No database window, nothing else.

I tried F11 and lookin in Window, but there is no database window at all.

I have tried importing tables into a separate database and the import dialog
box won't even come up.

The original file is still 2 GB in size, so the data is presumably there
somewhere.

I went to Help - Detect and Repair, but that didn't seem to do anythign for
me at all.

anyone ever experience this? Is there any way to get all of this back?
 
Ad

Advertisements

J

Jerry Whittle

First thing to do is to make a copy of the problem database before messing
with it any more.

You already attempted my first thought: importing into a new database file.

The is a better compact and repair tool called JetComp available from
Microsoft. It runs outside of Access and can fix things that a Compact and
Repair can't. Google for it.

I hate to ask, but how recent is your latest backup?

For other ideas Tony Toews has an excellent web page on database corruption.
Http://www.granite.ab.ca/access/corruptmdbs.htm

Allen Brown also has excellent info on corruption.
Http://allenbrowne.com/ser-47.html

I have a white paper in a Word document named Fix Corrupt Access Database
towards the bottom this page:
http://www.rogersaccesslibrary.com/OtherLibraries.asp
 
Ad

Advertisements

S

Sean Timmons

Thank you for the tips!

The JetComp wasn't able to fix the problem, but thankfully, I had a version
from 2 days prior available.

That's why we tell the kids to back up their data...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Database will not open 1
Opening a database 1
OPENING OF DATABASE 5
Database will not open 3
Opening databases 3
Database will not open 2
database will not open 1
Opening database 2

Top