Disappearing navagation bar


S

shifter jon

I finally finished and published my site that I made in Publisher. The site,
www.suicideshifters.com, works great when I use Google Chrome or Firefox to
view it (except the sound doesn't work). But when I try using Explorer the
navagation bar is missing and site is slow and glitchy (sound works). Any
ideas how to fix?
 
Ad

Advertisements

D

DavidF

There is a compatibility issue with IE8 and Publisher 2003 and 2007. Any
design elements that are 'grouped' together, which includes the Publisher
wizard built navbars, do not render when you view the web page in IE8 . The
fix in general is to ungroup the elements. There is both a manual fix to
these issues and a Service Patch that has been issued to fix it for Pub
2007.

Reference: Navigation bars and other content is missing from Publisher HTML
output in Internet Explorer 8: http://support.microsoft.com/kb/969705

A manual method of fixing this grouping issue:

After making and saving any changes to your Pub file, and prior to uploading
new web files, make a copy of your publication by doing a 'File > Save As'
and in this copy go to each page > Edit > Select All > Arrange > Ungroup.
This will ungroup the Publisher built navbar and disconnect it from the
wizard, and the navbars will render correctly in IE8. 'Publish to the Web'
from this copy of your publication. When you want to make further changes in
your web, go back to the original Publisher file, make the corrections
there, save your changes, and again make a copy, ungroup the
navbars and produce new web files for uploading. The advantage of this
workflow is that you will not have to rebuild the navbar if you choose to
add a page to the navbar. If you do not need to add a page or section to
your site, you can leave the navbar ungrouped and skip the step of saving a
copy.

Publisher 2007 can be fixed manually or with the Office 2007 SP2:

Reference: Description of 2007 Microsoft Office Suite Service Pack 2 (SP2)
and of Microsoft Office Language Pack 2007 SP2:
http://support.microsoft.com/?kbid=953195

Some users have found SP2 breaks Publisher, and makes it impossible to open
existing Pub files...you know, break one thing to fix another, so there is a
hotfix for that:

Description of the Publisher 2007 hotfix package (Publisher-x-none.msp):
October
27, 2009
http://support.microsoft.com/default.aspx/kb/976177/en-us

---------

You are using a lot of slow loading images. Be sure to run the compress
pictures function to speed up your page loading:

Reference: Compress graphics file sizes to create smaller Publisher Web
pages (2003):
http://office.microsoft.com/en-us/publisher/HA011266301033.aspx

Reference: Compress Pictures dialog box (2007):
http://office.microsoft.com/en-us/help/HA100363901033.aspx?pid=CL100605171033

DavidF
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top