endnote ref. numbers


K

karencheatham1

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen
 
Ad

Advertisements

D

Daiya Mitchell

Oh dear. I haven't a clue about this one, I hope someone else does? But I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why, but try
this:

A lot of settings are saved in the Normal template, which is the basis for
default new documents. So try making the change in the Normal template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc: Copy
everything except the last paragraph mark into a new default doc. Either hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to Select
All, shift-arrow to move the selection back one invisible paragraph mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to 1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya
 
J

John McGhie [MVP - Word and Word Macintosh]

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're the
Queen of EndNotes, if you don't know, what are the rest of us supposed to
do? :)

Let me add by two cents worth -- I think you're on the right track. I think
it's the template. However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it OFF,
then save the document.

The problem may be that every time the document is opened, Word attempts to
update the styles from the attached template. That mechanism is broken for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead, when the
style updates, Word attaches one of the default List Templates that are
built-in to the document structure. Voila! Default roman numerals each
time.

If you turn that setting OFF, Word does not try to update the styles, and
the list template (which defines the numbering format) remains associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the Microsoft
product planners, users who use styles and templates properly are not part
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too difficult to
take it out. But it has been broken ever since Word implemented list-based
numbering. You cannot use "Automatically update styles..." in a document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied, Word
associates a specific list template within the document to that style. You
subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by changing
the mechanism so that if "Automatically update styles..." was enabled for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically update
styles on open ON, even if the document is attached to the Normal template,
it will stay on and break the numbering every time you open the document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have the styles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

Oh dear. I haven't a clue about this one, I hope someone else does? But I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why, but try
this:

A lot of settings are saved in the Normal template, which is the basis for
default new documents. So try making the change in the Normal template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc: Copy
everything except the last paragraph mark into a new default doc. Either hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to Select
All, shift-arrow to move the selection back one invisible paragraph mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to 1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
D

Daiya Mitchell

Hi John,

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're the
Queen of EndNotes, if you don't know, what are the rest of us supposed to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured I had
to respond, or else you all might just leave it for me. :)
Let me add by two cents worth -- I think you're on the right track. I think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to ii,iii
for endnotes, so I guess it is saved there.
However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal. I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya
 
K

karencheatham1

I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen
 
D

Daiya Mitchell

And you tried copying into a new document without the last paragraph mark,
and that freshly created doc is still acting up?

I'm out of guesses. Anybody? Like said, I've received a doc on my Mac that
this happened with, so I don't think it's as simple as that, sadly.

Workaround--if the recipients are just going to print it to read, send as a
PDF?
 
Ad

Advertisements

K

karencheatham1

Yes, I copied into a new document without the last paragraph mark.
When I did it, I followed your second set of instructions for removing
the P mark. Just in case I didn't backspace enough, or whatever, I've
done it again this time clicking on the P mark on the standard menu and
leaving out the last P. I'll let you know how the test goes.
Karen

Daiya said:
And you tried copying into a new document without the last paragraph mark,
and that freshly created doc is still acting up?

I'm out of guesses. Anybody? Like said, I've received a doc on my Mac that
this happened with, so I don't think it's as simple as that, sadly.

Workaround--if the recipients are just going to print it to read, send asa
PDF?


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya said:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]" wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're the
Queen of EndNotes, if you don't know, what are the rest of us supposed to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured Ihad
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal.I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word attempts to
update the styles from the attached template. That mechanism is broken for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead, when the
style updates, Word attaches one of the default List Templates that are
built-in to the document structure. Voila! Default roman numerals each
time.

If you turn that setting OFF, Word does not try to update the styles,and
the list template (which defines the numbering format) remains associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the Microsoft
product planners, users who use styles and templates properly are notpart
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too difficult to
take it out. But it has been broken ever since Word implemented list-based
numbering. You cannot use "Automatically update styles..." in a document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied, Word
associates a specific list template within the document to that style.. You
subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by changing
the mechanism so that if "Automatically update styles..." was enabledfor
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically update
styles on open ON, even if the document is attached to the Normal template,
it will stay on and break the numbering every time you open the document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have thestyles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does?But I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why,but
try
this:

A lot of settings are saved in the Normal template, which is the basis for
default new documents. So try making the change in the Normal template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc: Copy
everything except the last paragraph mark into a new default doc. Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a toSelect
All, shift-arrow to move the selection back one invisible paragraph mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen

--
Daiya Mitchell, MVP Mac/Word
Word FAQ: http://www.word.mvps.org/
MacWord Tips: <http://word.mvps.org/Mac/WordMacHome.html>
What's an MVP? A volunteer! Read the FAQ:
 
J

John McGhie [MVP - Word and Word Macintosh]

Hi Daiya:

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal. I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

It doesn't matter WHAT is stored in the template, because the list template
stored in the template is not copied into the document. That's the bug!

If you update styles on open from template, the style comes in to the
document, with a pointer that shows that it *should* be linked to the list
template.

However, the list template does NOT get copied in.

So Word associates the style coming in with a fresh new DEFAULT list
template, and the default list template chosen for endnote numbering has
Roman numbers.

That's the way I think it "doesn't work".

For years, we have been struggling to make this work. Some people were
suggesting that if you use Organiser Copy to update numbered styles, and you
copy three times, you will bring the list template in on the second copy and
attach it to the style on the third. I think this is an old spouse's tale:
I don't think it's reliable.

Cheers

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
J

John McGhie [MVP - Word and Word Macintosh]

Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing how to
DELETE the Word Data Key from the Windows Registry. When you do that, Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate correctly.

Hope this helps


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
K

karencheatham1

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing how to
DELETE the Word Data Key from the Windows Registry. When you do that, Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate correctly.

Hope this helps


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya said:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]" wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're the
Queen of EndNotes, if you don't know, what are the rest of us supposed to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured Ihad
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal.I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word attempts to
update the styles from the attached template. That mechanism is broken for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead, when the
style updates, Word attaches one of the default List Templates that are
built-in to the document structure. Voila! Default roman numerals each
time.

If you turn that setting OFF, Word does not try to update the styles,and
the list template (which defines the numbering format) remains associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the Microsoft
product planners, users who use styles and templates properly are notpart
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too difficult to
take it out. But it has been broken ever since Word implemented list-based
numbering. You cannot use "Automatically update styles..." in a document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied, Word
associates a specific list template within the document to that style.. You
subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by changing
the mechanism so that if "Automatically update styles..." was enabledfor
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically update
styles on open ON, even if the document is attached to the Normal template,
it will stay on and break the numbering every time you open the document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have thestyles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article C108DDC4.7187B%daiyaNOSPAM[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does?But I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why,but
try
this:

A lot of settings are saved in the Normal template, which is the basis for
default new documents. So try making the change in the Normal template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc: Copy
everything except the last paragraph mark into a new default doc. Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a toSelect
All, shift-arrow to move the selection back one invisible paragraph mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
Ad

Advertisements

J

John McGhie [MVP - Word and Word Macintosh]

Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex under the
hood. I know: it shouldn't be, but it is. They were trying to provide
ultimate flexibility. Well, they succeeded. At the expense of massive
complexity.

So now I need to ask HOW you removed the field codes, and what specifically
you deleted. Sorry, but I need massive detail here. A Word document is a
huge ball of string: hundreds of thousands of interlocking pointers to
objects. Each number should have a pointer to a List Template that should
have a pointer to a single Style. If those pointers get disturbed, all hell
can break lose: if you tell me how you went about removing the field codes I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to explain: just
send one. As an attachment in a Plain Text email. My Spam Filter shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what you want
to read, and include the word "Microsoft" in the query. Try "Microsoft Word
delete data key". Note the capitalisation: in Google it's significant.

Cheers

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing how to
DELETE the Word Data Key from the Windows Registry. When you do that, Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate correctly.

Hope this helps


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]" wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're
the
Queen of EndNotes, if you don't know, what are the rest of us supposed to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured I had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal. I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word attempts
to
update the styles from the attached template. That mechanism is broken
for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead, when
the
style updates, Word attaches one of the default List Templates that are
built-in to the document structure. Voila! Default roman numerals each
time.

If you turn that setting OFF, Word does not try to update the styles, and
the list template (which defines the numbering format) remains associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the Microsoft
product planners, users who use styles and templates properly are not part
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied,
Word
associates a specific list template within the document to that style.
You
subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by changing
the mechanism so that if "Automatically update styles..." was enabled for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically update
styles on open ON, even if the document is attached to the Normal
template,
it will stay on and break the numbering every time you open the document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have the
styles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does? But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why, but
try
this:

A lot of settings are saved in the Normal template, which is the basis
for
default new documents. So try making the change in the Normal template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc: Copy
everything except the last paragraph mark into a new default doc. Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to Select
All, shift-arrow to move the selection back one invisible paragraph mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
K

karencheatham1

Hi John,
I sent you the document as an attachment--hope it survives your junk
filter. Answering your questions:
-I removed field codes by going into the EndNote tools menu and hitting
'remove field codes'. It creates a new document and I saved that
document under a new name.
-When you ask 'what I deleted' are you referring to the Paragraph
Marks? I did not do any other deleting when I removed field codes.
When I deleted P marks, I deleted all of the P marks that were at the
end of the text (not the end of the endnotes, since select all only
hightlights the text). I clearly deleted too many b/c It took the
formatting out of my last paragraph, so I had to reapply my line
spacing.
Karen
Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex under the
hood. I know: it shouldn't be, but it is. They were trying to provide
ultimate flexibility. Well, they succeeded. At the expense of massive
complexity.

So now I need to ask HOW you removed the field codes, and what specifically
you deleted. Sorry, but I need massive detail here. A Word document is a
huge ball of string: hundreds of thousands of interlocking pointers to
objects. Each number should have a pointer to a List Template that should
have a pointer to a single Style. If those pointers get disturbed, all hell
can break lose: if you tell me how you went about removing the field codes I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to explain: just
send one. As an attachment in a Plain Text email. My Spam Filter shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what you want
to read, and include the word "Microsoft" in the query. Try "Microsoft Word
delete data key". Note the capitalisation: in Google it's significant.

Cheers

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing howto
DELETE the Word Data Key from the Windows Registry. When you do that,Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registrycan
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate correctly.

Hope this helps


On 18/8/06 4:31 AM, in article
(e-mail address removed),


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]" wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're
the
Queen of EndNotes, if you don't know, what are the rest of us supposed to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figuredI had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track.I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal. I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word attempts
to
update the styles from the attached template. That mechanism is broken
for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead,when
the
style updates, Word attaches one of the default List Templates thatare
built-in to the document structure. Voila! Default roman numeralseach
time.

If you turn that setting OFF, Word does not try to update the styles, and
the list template (which defines the numbering format) remains associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the Microsoft
product planners, users who use styles and templates properly are not part
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied,
Word
associates a specific list template within the document to that style.
You
subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by changing
the mechanism so that if "Automatically update styles..." was enabled for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically update
styles on open ON, even if the document is attached to the Normal
template,
it will stay on and break the numbering every time you open the document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should againbe
possible to attach a document to an external style sheet and have the
styles
update without breaking the numbering. We need to ensure that thisis
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does? But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why, but
try
this:

A lot of settings are saved in the Normal template, which is the basis
for
default new documents. So try making the change in the Normal template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers to
1,2,3. Then delete the endnote, and any accidental spaces or text.Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc: Copy
everything except the last paragraph mark into a new default doc. Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to Select
All, shift-arrow to move the selection back one invisible paragraph mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is setto
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen



--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
B

Beth Rosengard

From Google:

"Google searches are NOT case sensitive. All letters, regardless of how you
type them, will be understood as lower case. For example, searches for
george washington, George Washington, and gEoRgE wAsHiNgToN will all return
the same results."

Beth
 
J

John McGhie [MVP - Word and Word Macintosh]

Hi Karen:

Nope: Nothing received at this end.

Make sure the email is plain text and there *is* some text, and that the
attachment is an *attachment*.

Anything else looks like either spam or a virus and meets a grizzly fate :)

The number formatting is contained in the paragraph marks (actually, the
paragraph marks contain a hexadecimal pointer to the table that contains the
number formatting, but you get what I mean). So if you have been fiddling
with paragraph marks then things are becoming a bit interesting.

I'll need to have a look at that thing: please re-send.

cheers


Hi John,
I sent you the document as an attachment--hope it survives your junk
filter. Answering your questions:
-I removed field codes by going into the EndNote tools menu and hitting
'remove field codes'. It creates a new document and I saved that
document under a new name.
-When you ask 'what I deleted' are you referring to the Paragraph
Marks? I did not do any other deleting when I removed field codes.
When I deleted P marks, I deleted all of the P marks that were at the
end of the text (not the end of the endnotes, since select all only
hightlights the text). I clearly deleted too many b/c It took the
formatting out of my last paragraph, so I had to reapply my line
spacing.
Karen
Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex under the
hood. I know: it shouldn't be, but it is. They were trying to provide
ultimate flexibility. Well, they succeeded. At the expense of massive
complexity.

So now I need to ask HOW you removed the field codes, and what specifically
you deleted. Sorry, but I need massive detail here. A Word document is a
huge ball of string: hundreds of thousands of interlocking pointers to
objects. Each number should have a pointer to a List Template that should
have a pointer to a single Style. If those pointers get disturbed, all hell
can break lose: if you tell me how you went about removing the field codes I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to explain: just
send one. As an attachment in a Plain Text email. My Spam Filter shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what you want
to read, and include the word "Microsoft" in the query. Try "Microsoft Word
delete data key". Note the capitalisation: in Google it's significant.

Cheers

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing how to
DELETE the Word Data Key from the Windows Registry. When you do that, Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these
PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate correctly.

Hope this helps


On 18/8/06 4:31 AM, in article
(e-mail address removed),


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]" wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're
the
Queen of EndNotes, if you don't know, what are the rest of us supposed
to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured I
had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it
OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal. I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word attempts
to
update the styles from the attached template. That mechanism is broken
for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead, when
the
style updates, Word attaches one of the default List Templates that are
built-in to the document structure. Voila! Default roman numerals each
time.

If you turn that setting OFF, Word does not try to update the styles,
and
the list template (which defines the numbering format) remains
associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the
Microsoft
product planners, users who use styles and templates properly are not
part
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too
difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a
document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied,
Word
associates a specific list template within the document to that style.
You

subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts
to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by
changing
the mechanism so that if "Automatically update styles..." was enabled
for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically
update
styles on open ON, even if the document is attached to the Normal
template,
it will stay on and break the numbering every time you open the
document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have the
styles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does?
But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why,
but
try
this:

A lot of settings are saved in the Normal template, which is the basis
for
default new documents. So try making the change in the Normal
template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for
YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers
to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc:
Copy
everything except the last paragraph mark into a new default doc.
Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to
Select
All, shift-arrow to move the selection back one invisible paragraph
mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts
on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference
numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen



--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
J

John McGhie [MVP - Word and Word Macintosh]

Oh. Coulda sworn they used to be {sigh}


From Google:

"Google searches are NOT case sensitive. All letters, regardless of how you
type them, will be understood as lower case. For example, searches for
george washington, George Washington, and gEoRgE wAsHiNgToN will all return
the same results."

Beth

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
Ad

Advertisements

K

karencheatham1

John,
Ok, so there's nothing called 'plain text' on my list of options (when
i hit 'save as' and look under the drop down menu next to 'format').
What next?

Also, I've only been fiddling with paragraph marks to the extent that I
followed Daiya's very detailed instructions on how to delete the final
paragraph mark in my document in an attempt to correct the problem with
the endnote numbering. The document I'm sending you, however, is not
the test document, with final P removed. It is the original document
with the magically appearing roman numerals.
Karen
Hi Karen:

Nope: Nothing received at this end.

Make sure the email is plain text and there *is* some text, and that the
attachment is an *attachment*.

Anything else looks like either spam or a virus and meets a grizzly fate :)

The number formatting is contained in the paragraph marks (actually, the
paragraph marks contain a hexadecimal pointer to the table that contains the
number formatting, but you get what I mean). So if you have been fiddling
with paragraph marks then things are becoming a bit interesting.

I'll need to have a look at that thing: please re-send.

cheers


Hi John,
I sent you the document as an attachment--hope it survives your junk
filter. Answering your questions:
-I removed field codes by going into the EndNote tools menu and hitting
'remove field codes'. It creates a new document and I saved that
document under a new name.
-When you ask 'what I deleted' are you referring to the Paragraph
Marks? I did not do any other deleting when I removed field codes.
When I deleted P marks, I deleted all of the P marks that were at the
end of the text (not the end of the endnotes, since select all only
hightlights the text). I clearly deleted too many b/c It took the
formatting out of my last paragraph, so I had to reapply my line
spacing.
Karen
Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex underthe
hood. I know: it shouldn't be, but it is. They were trying to provide
ultimate flexibility. Well, they succeeded. At the expense of massive
complexity.

So now I need to ask HOW you removed the field codes, and what specifically
you deleted. Sorry, but I need massive detail here. A Word document is a
huge ball of string: hundreds of thousands of interlocking pointers to
objects. Each number should have a pointer to a List Template that should
have a pointer to a single Style. If those pointers get disturbed, all hell
can break lose: if you tell me how you went about removing the field codes I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to explain:just
send one. As an attachment in a Plain Text email. My Spam Filter shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what you want
to read, and include the word "Microsoft" in the query. Try "Microsoft Word
delete data key". Note the capitalisation: in Google it's significant.

Cheers

On 19/8/06 12:50 AM, in article
(e-mail address removed),

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing how to
DELETE the Word Data Key from the Windows Registry. When you do that, Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these
PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate correctly.

Hope this helps


On 18/8/06 4:31 AM, in article
(e-mail address removed),


I'm sorry to have left you hanging, but I had to wait for my guineapig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open"set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]"wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :) You're
the
Queen of EndNotes, if you don't know, what are the rest of us supposed
to
do? :)

No, I don't think she is using EndNote the program, just endnotes.And
actually, I think Corentin is the King there. :) But yes, I figured I
had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted backto
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turnit
OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it can't
have been picking them up from my settings, which are 1,2,3 in Normal. I
checked that document that I received, and it isn't set to automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word attempts
to
update the styles from the attached template. That mechanism is broken
for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead, when
the
style updates, Word attaches one of the default List Templates that are
built-in to the document structure. Voila! Default roman numerals each
time.

If you turn that setting OFF, Word does not try to update the styles,
and
the list template (which defines the numbering format) remains
associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the
Microsoft
product planners, users who use styles and templates properly arenot
part
of their user base. They're trying to dumb Word down to make it compete
with Pages :)

The only reason we still have the mechanism is because it's too
difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a
document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied,
Word
associates a specific list template within the document to that style.
You

subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts
to
update the style. If the style is updated, the connection to thelist
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by
changing
the mechanism so that if "Automatically update styles..." was enabled
for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically
update
styles on open ON, even if the document is attached to the Normal
template,
it will stay on and break the numbering every time you open the
document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and havethe
styles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does?
But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why,
but
try
this:

A lot of settings are saved in the Normal template, which is thebasis
for
default new documents. So try making the change in the Normal
template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for
YourUserHome).
Double-click Normal to open it. Insert an endnote, change the numbers
to
1,2,3. Then delete the endnote, and any accidental spaces or text. Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc:
Copy
everything except the last paragraph mark into a new default doc.
Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to
Select
All, shift-arrow to move the selection back one invisible paragraph
mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it reverts
on
your own machine. If it does, then you can test your own seconddoc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use arabic
numbers instead. When I email my document as a Word attachmentto
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference
numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen



--

Please reply to the newsgroup to maintain the thread. Please do notemail
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410


--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
D

Dave Minerath

I think he meant send the email as plain text, not the document itself. If
you use Entourage as your email client, you will see a red ab and a blue ab
next to the font menu item (look in upper left of the message area). Click
this to toggle between a plain text email and an HTML email.

If you can use bold type, italics, etc. in your email message, you are
sending it as HTML. Click the aforementioned button and it will change to
plain text. When the dialog box comes up asking if you want to clear HTML
formatting, select yes. Sending plain text will still allow attachments.

Dave

John,
Ok, so there's nothing called 'plain text' on my list of options (when
i hit 'save as' and look under the drop down menu next to 'format').
What next?

Also, I've only been fiddling with paragraph marks to the extent that I
followed Daiya's very detailed instructions on how to delete the final
paragraph mark in my document in an attempt to correct the problem with
the endnote numbering. The document I'm sending you, however, is not
the test document, with final P removed. It is the original document
with the magically appearing roman numerals.
Karen
Hi Karen:

Nope: Nothing received at this end.

Make sure the email is plain text and there *is* some text, and that the
attachment is an *attachment*.

Anything else looks like either spam or a virus and meets a grizzly fate :)

The number formatting is contained in the paragraph marks (actually, the
paragraph marks contain a hexadecimal pointer to the table that contains the
number formatting, but you get what I mean). So if you have been fiddling
with paragraph marks then things are becoming a bit interesting.

I'll need to have a look at that thing: please re-send.

cheers


Hi John,
I sent you the document as an attachment--hope it survives your junk
filter. Answering your questions:
-I removed field codes by going into the EndNote tools menu and hitting
'remove field codes'. It creates a new document and I saved that
document under a new name.
-When you ask 'what I deleted' are you referring to the Paragraph
Marks? I did not do any other deleting when I removed field codes.
When I deleted P marks, I deleted all of the P marks that were at the
end of the text (not the end of the endnotes, since select all only
hightlights the text). I clearly deleted too many b/c It took the
formatting out of my last paragraph, so I had to reapply my line
spacing.
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex under the
hood. I know: it shouldn't be, but it is. They were trying to provide
ultimate flexibility. Well, they succeeded. At the expense of massive
complexity.

So now I need to ask HOW you removed the field codes, and what specifically
you deleted. Sorry, but I need massive detail here. A Word document is a
huge ball of string: hundreds of thousands of interlocking pointers to
objects. Each number should have a pointer to a List Template that should
have a pointer to a single Style. If those pointers get disturbed, all
hell
can break lose: if you tell me how you went about removing the field codes
I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to explain: just
send one. As an attachment in a Plain Text email. My Spam Filter shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what you
want
to read, and include the word "Microsoft" in the query. Try "Microsoft
Word
delete data key". Note the capitalisation: in Google it's significant.

Cheers

On 19/8/06 12:50 AM, in article
(e-mail address removed),

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing how to
DELETE the Word Data Key from the Windows Registry. When you do that,
Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry
can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that these
PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate
correctly.

Hope this helps


On 18/8/06 4:31 AM, in article
(e-mail address removed),


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]"
wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :)
You're
the
Queen of EndNotes, if you don't know, what are the rest of us supposed
to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured I
had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it
OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes, it
can't
have been picking them up from my settings, which are 1,2,3 in Normal.
I
checked that document that I received, and it isn't set to
automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word
attempts
to
update the styles from the attached template. That mechanism is
broken
for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead,
when
the
style updates, Word attaches one of the default List Templates that
are
built-in to the document structure. Voila! Default roman numerals
each
time.

If you turn that setting OFF, Word does not try to update the styles,
and
the list template (which defines the numbering format) remains
associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the
Microsoft
product planners, users who use styles and templates properly are not
part
of their user base. They're trying to dumb Word down to make it
compete
with Pages :)

The only reason we still have the mechanism is because it's too
difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a
document
that also contains list-based numbering. And EndNote numbering is
list-based numbering. Applied by a style. When the style is applied,
Word
associates a specific list template within the document to that style.
You

subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts
to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by
changing
the mechanism so that if "Automatically update styles..." was enabled
for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically
update
styles on open ON, even if the document is attached to the Normal
template,
it will stay on and break the numbering every time you open the
document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and
make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have the
styles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else does?
But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why,
but
try
this:

A lot of settings are saved in the Normal template, which is the
basis
for
default new documents. So try making the change in the Normal
template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for
YourUserHome).
Double-click Normal to open it. Insert an endnote, change the
numbers
to
1,2,3. Then delete the endnote, and any accidental spaces or text.
Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problem doc:
Copy
everything except the last paragraph mark into a new default doc.
Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to
Select
All, shift-arrow to move the selection back one invisible paragraph
mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is set to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it
reverts
on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have
composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use
arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference
numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen



--

Please reply to the newsgroup to maintain the thread. Please do not
email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410


--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410

--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
K

karencheatham1

Thanks Dave--that helped! The email was already in plain text, but
I've resent it and am crossing my fingers.
K

Dave said:
I think he meant send the email as plain text, not the document itself. If
you use Entourage as your email client, you will see a red ab and a blue ab
next to the font menu item (look in upper left of the message area). Click
this to toggle between a plain text email and an HTML email.

If you can use bold type, italics, etc. in your email message, you are
sending it as HTML. Click the aforementioned button and it will change to
plain text. When the dialog box comes up asking if you want to clear HTML
formatting, select yes. Sending plain text will still allow attachments.

Dave

John,
Ok, so there's nothing called 'plain text' on my list of options (when
i hit 'save as' and look under the drop down menu next to 'format').
What next?

Also, I've only been fiddling with paragraph marks to the extent that I
followed Daiya's very detailed instructions on how to delete the final
paragraph mark in my document in an attempt to correct the problem with
the endnote numbering. The document I'm sending you, however, is not
the test document, with final P removed. It is the original document
with the magically appearing roman numerals.
Karen
Hi Karen:

Nope: Nothing received at this end.

Make sure the email is plain text and there *is* some text, and that the
attachment is an *attachment*.

Anything else looks like either spam or a virus and meets a grizzly fate :)

The number formatting is contained in the paragraph marks (actually, the
paragraph marks contain a hexadecimal pointer to the table that contains the
number formatting, but you get what I mean). So if you have been fiddling
with paragraph marks then things are becoming a bit interesting.

I'll need to have a look at that thing: please re-send.

cheers


On 19/8/06 10:50 PM, in article
(e-mail address removed),

Hi John,
I sent you the document as an attachment--hope it survives your junk
filter. Answering your questions:
-I removed field codes by going into the EndNote tools menu and hitting
'remove field codes'. It creates a new document and I saved that
document under a new name.
-When you ask 'what I deleted' are you referring to the Paragraph
Marks? I did not do any other deleting when I removed field codes.
When I deleted P marks, I deleted all of the P marks that were at the
end of the text (not the end of the endnotes, since select all only
hightlights the text). I clearly deleted too many b/c It took the
formatting out of my last paragraph, so I had to reapply my line
spacing.
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex under the
hood. I know: it shouldn't be, but it is. They were trying to provide
ultimate flexibility. Well, they succeeded. At the expense of massive
complexity.

So now I need to ask HOW you removed the field codes, and what specifically
you deleted. Sorry, but I need massive detail here. A Word document is a
huge ball of string: hundreds of thousands of interlocking pointers to
objects. Each number should have a pointer to a List Template that should
have a pointer to a single Style. If those pointers get disturbed, all
hell
can break lose: if you tell me how you went about removing the fieldcodes
I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to explain: just
send one. As an attachment in a Plain Text email. My Spam Filter shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what you
want
to read, and include the word "Microsoft" in the query. Try "Microsoft
Word
delete data key". Note the capitalisation: in Google it's significant.

Cheers

On 19/8/06 12:50 AM, in article
(e-mail address removed),

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my document
using EndNote but the field codes have been removed from the document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Hmmm.... The number format for a list template can be stored, in binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describinghow to
DELETE the Word Data Key from the Windows Registry. When you do that,
Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the Registry
can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed thatthese
PCs
had had documents with numbering opened on them before. If they had, the
numbering preferences should be set in the Data Key and operate
correctly.

Hope this helps


On 18/8/06 4:31 AM, in article
(e-mail address removed),


I'm sorry to have left you hanging, but I had to wait for my guinea pig
to respond before i could be sure that the problem was fixed. Sadly,
it isn't! I did not have the "Automatically update styles on open" set
to ON so I followed the procedure suggested by Daiya. It reset the
default (thank you!) but when my test document was received it still
opened up with roman numerals. I don't know if this makes a difference
but for some recipients of the document (then and now) it opens up with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word Macintosh]"
wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :)
You're
the
Queen of EndNotes, if you don't know, what are the rest of us supposed
to
do? :)

No, I don't think she is using EndNote the program, just endnotes. And
actually, I think Corentin is the King there. :) But yes, I figured I
had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right track. I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted back to
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in Tools>Templates and
Add-ins... If the "Automatically update..." box is checked, turn it
OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes,it
can't
have been picking them up from my settings, which are 1,2,3 in Normal.
I
checked that document that I received, and it isn't set to
automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word
attempts
to
update the styles from the attached template. That mechanism is
broken
for
numbered styles: it updates the "Style" but it disassociates the "List
Template" that should remain attached to match the style. Instead,
when
the
style updates, Word attaches one of the default List Templates that
are
built-in to the document structure. Voila! Default roman numerals
each
time.

If you turn that setting OFF, Word does not try to update the styles,
and
the list template (which defines the numbering format) remains
associated.

Microsoft refuses to fix this mechanism, because they do not really
understand the purpose of "Automatically update styles". To the
Microsoft
product planners, users who use styles and templates properly are not
part
of their user base. They're trying to dumb Word down to make it
compete
with Pages :)

The only reason we still have the mechanism is because it's too
difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a
document
that also contains list-based numbering. And EndNote numberingis
list-based numbering. Applied by a style. When the style is applied,
Word
associates a specific list template within the document to thatstyle.
You

subsequently reset the numbering format (the List Template) to your
preference. It will stay the way you set it unless something attempts
to
update the style. If the style is updated, the connection to the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by
changing
the mechanism so that if "Automatically update styles..." was enabled
for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set Automatically
update
styles on open ON, even if the document is attached to the Normal
template,
it will stay on and break the numbering every time you open the
document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off and
make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should again be
possible to attach a document to an external style sheet and have the
styles
update without breaking the numbering. We need to ensure that this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone elsedoes?
But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure why,
but
try
this:

A lot of settings are saved in the Normal template, which is the
basis
for
default new documents. So try making the change in the Normal
template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for
YourUserHome).
Double-click Normal to open it. Insert an endnote, change the
numbers
to
1,2,3. Then delete the endnote, and any accidental spaces or text.
Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is 1,2,3.

If that worked to change the default, try this on your problemdoc:
Copy
everything except the last paragraph mark into a new default doc.
Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a to
Select
All, shift-arrow to move the selection back one invisible paragraph
mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default isset to
1,2,3,
it won't revert when you email it. It's also possible that the last
paragraph mark carried some corruption that was causing the problem.

You might email the known-problem doc to yourself to see if it
reverts
on
your own machine. If it does, then you can test your own second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have
composed
a large document that contains endnotes. For endnote reference
numbers, Word defaults at roman numerals, but I tell it to use
arabic
numbers instead. When I email my document as a Word attachment to
others and they open it, the endnote reference numbers have all
reverted to roman numerals. Help please! I need the reference
numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so thatthe
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen



--

Please reply to the newsgroup to maintain the thread. Please do not
email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410


--

Please reply to the newsgroup to maintain the thread. Please do notemail
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410


--

Please reply to the newsgroup to maintain the thread. Please do not email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical Writer
Sydney, Australia +61 (0) 4 1209 1410
 
Ad

Advertisements

J

John McGhie [MVP -- Word and Word Mac]

Hi Karen:

Sorry, no email fom you yet. Please send a copy to yourself as well to make
sure it's actually leaving your computer :)

It's not even hitting my junk mail folder, so it's either going to the wrong
address or it has a virus in it :) Try Zipping/Stuffing the document: that
may make a difference.

Cheers

--

John McGhie <[email protected]>
Consultant Technical Writer, Microsoft MVP (Word, Word for Mac)
Sydney, Australia +61 (0)4 1209 1410

Thanks Dave--that helped! The email was already in plain text, but
I've resent it and am crossing my fingers.
K

Dave said:
I think he meant send the email as plain text, not the document itself.
If
you use Entourage as your email client, you will see a red ab and a blue
ab
next to the font menu item (look in upper left of the message area).
Click
this to toggle between a plain text email and an HTML email.

If you can use bold type, italics, etc. in your email message, you are
sending it as HTML. Click the aforementioned button and it will change to
plain text. When the dialog box comes up asking if you want to clear HTML
formatting, select yes. Sending plain text will still allow attachments.

Dave

John,
Ok, so there's nothing called 'plain text' on my list of options (when
i hit 'save as' and look under the drop down menu next to 'format').
What next?

Also, I've only been fiddling with paragraph marks to the extent that I
followed Daiya's very detailed instructions on how to delete the final
paragraph mark in my document in an attempt to correct the problem with
the endnote numbering. The document I'm sending you, however, is not
the test document, with final P removed. It is the original document
with the magically appearing roman numerals.
Karen
Hi Karen:

Nope: Nothing received at this end.

Make sure the email is plain text and there *is* some text, and that
the
attachment is an *attachment*.

Anything else looks like either spam or a virus and meets a grizzly
fate :)

The number formatting is contained in the paragraph marks (actually,
the
paragraph marks contain a hexadecimal pointer to the table that
contains the
number formatting, but you get what I mean). So if you have been
fiddling
with paragraph marks then things are becoming a bit interesting.

I'll need to have a look at that thing: please re-send.

cheers


On 19/8/06 10:50 PM, in article
(e-mail address removed),

Hi John,
I sent you the document as an attachment--hope it survives your junk
filter. Answering your questions:
-I removed field codes by going into the EndNote tools menu and
hitting
'remove field codes'. It creates a new document and I saved that
document under a new name.
-When you ask 'what I deleted' are you referring to the Paragraph
Marks? I did not do any other deleting when I removed field codes.
When I deleted P marks, I deleted all of the P marks that were at the
end of the text (not the end of the endnotes, since select all only
hightlights the text). I clearly deleted too many b/c It took the
formatting out of my last paragraph, so I had to reapply my line
spacing.
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Numbering (ALL numbering) in Microsoft Word is massively complex
under the
hood. I know: it shouldn't be, but it is. They were trying to
provide
ultimate flexibility. Well, they succeeded. At the expense of
massive
complexity.

So now I need to ask HOW you removed the field codes, and what
specifically
you deleted. Sorry, but I need massive detail here. A Word document
is a
huge ball of string: hundreds of thousands of interlocking pointers
to
objects. Each number should have a pointer to a List Template that
should
have a pointer to a single Style. If those pointers get disturbed,
all
hell
can break lose: if you tell me how you went about removing the field
codes
I
can begin to hazard a guess as to the current state of the document.

Better flip me a copy, I think. It's probably too complex to
explain: just
send one. As an attachment in a Plain Text email. My Spam Filter
shoots
anything else before I see it :)

The fastest way to find anything in the MS KB is to Google for what
you
want
to read, and include the word "Microsoft" in the query. Try
"Microsoft
Word
delete data key". Note the capitalisation: in Google it's
significant.

Cheers

On 19/8/06 12:50 AM, in article
(e-mail address removed),

Hi,
First: No luck with the second test email.

John, I don't know what or where the Microsoft Knowledge Base is.
Could you direct me to it?

Btw, in case this has any bearing on things: I did create my
document
using EndNote but the field codes have been removed from the
document
I'm sending so I assumed the info. wasn't relevant.

Thanks much,
Karen

John McGhie [MVP - Word and Word Macintosh] wrote:
Hi Karen:

Hmmm.... The number format for a list template can be stored, in
binary
format, in the Windows Registry.

There is an instruction on the Microsoft Knowledge Base describing
how to
DELETE the Word Data Key from the Windows Registry. When you do
that,
Word
will rebuild it on the next start.

That may solve your problem. Apparently, the Data Key in the
Registry
can
corrupt, and that may be what has happened.

The reason I did not mention it before was that I had assumed that
these
PCs
had had documents with numbering opened on them before. If they
had, the
numbering preferences should be set in the Data Key and operate
correctly.

Hope this helps


On 18/8/06 4:31 AM, in article
(e-mail address removed),


I'm sorry to have left you hanging, but I had to wait for my
guinea pig
to respond before i could be sure that the problem was fixed.
Sadly,
it isn't! I did not have the "Automatically update styles on
open" set
to ON so I followed the procedure suggested by Daiya. It reset
the
default (thank you!) but when my test document was received it
still
opened up with roman numerals. I don't know if this makes a
difference
but for some recipients of the document (then and now) it opens up
with
arabic numbers, just as I saved it, but others get it with roman
numerals. The one for whom it opens up just dandy has a mac, the
others (I think) have pcs.
Karen

Daiya Mitchell wrote:
Hi John,

On 8/17/06 4:42 AM, "John McGhie [MVP - Word and Word
Macintosh]"
wrote:

Hi Daiya:

Excuse me! You do not get to bail out of EndNote questions :)
You're
the
Queen of EndNotes, if you don't know, what are the rest of us
supposed
to
do? :)

No, I don't think she is using EndNote the program, just
endnotes. And
actually, I think Corentin is the King there. :) But yes, I
figured I
had
to respond, or else you all might just leave it for me. :)

Let me add by two cents worth -- I think you're on the right
track. I
think
it's the template.

I did check my previous guess later--a fresh Normal defaulted
back to
ii,iii
for endnotes, so I guess it is saved there.

However, I suggest that it won't matter much WHAT is in
the Template, the problem is that the template is Attached with
"Automatically update styles on open" set to ON.

If the user were to open the document and check in
Tools>Templates and
Add-ins... If the "Automatically update..." box is checked,
turn it
OFF,
then save the document.

Logical--except that when I received a doc and saw ii,iii notes,
it
can't
have been picking them up from my settings, which are 1,2,3 in
Normal.
I
checked that document that I received, and it isn't set to
automatically
update styles, but I have already edited and resaved it, so....

Daiya


The problem may be that every time the document is opened, Word
attempts
to
update the styles from the attached template. That mechanism is
broken
for
numbered styles: it updates the "Style" but it disassociates the
"List
Template" that should remain attached to match the style.
Instead,
when
the
style updates, Word attaches one of the default List Templates
that
are
built-in to the document structure. Voila! Default roman
numerals
each
time.

If you turn that setting OFF, Word does not try to update the
styles,
and
the list template (which defines the numbering format) remains
associated.

Microsoft refuses to fix this mechanism, because they do not
really
understand the purpose of "Automatically update styles". To the
Microsoft
product planners, users who use styles and templates properly
are not
part
of their user base. They're trying to dumb Word down to make it
compete
with Pages :)

The only reason we still have the mechanism is because it's too
difficult
to
take it out. But it has been broken ever since Word implemented
list-based
numbering. You cannot use "Automatically update styles..." in a
document
that also contains list-based numbering. And EndNote numbering
is
list-based numbering. Applied by a style. When the style is
applied,
Word
associates a specific list template within the document to that
style.
You

subsequently reset the numbering format (the List Template) to
your
preference. It will stay the way you set it unless something
attempts
to
update the style. If the style is updated, the connection to
the list
template is broken, and the numbering changes.

Back a few versions, Microsoft attempted to lessen the damage by
changing
the mechanism so that if "Automatically update styles..." was
enabled
for
the Normal template, it would be ignored and switched off.

That change now seems to have been lost. If you set
Automatically
update
styles on open ON, even if the document is attached to the
Normal
template,
it will stay on and break the numbering every time you open the
document.
And that's what I think is happening.

The only thing I can suggest is that you turn that setting off
and
make
sure
that nobody else turns it on.

One more ray of hope: In the next version of Word, it should
again be
possible to attach a document to an external style sheet and
have the
styles
update without breaking the numbering. We need to ensure that
this is
tested carefully during the beta!

Cheers

On 17/8/06 7:35 AM, in article
C108DDC4.7187B%[email protected],

Oh dear. I haven't a clue about this one, I hope someone else
does?
But
I
have been on the receiving end of it.

Somehow, however, my endnotes do default to 1,2,3. I'm not sure
why,
but
try
this:

A lot of settings are saved in the Normal template, which is
the
basis
for
default new documents. So try making the change in the Normal
template.

To do this, navigate to Normal (unless you changed it, it's at
~:Documents:Microsoft User Data:Normal, where ~ stands for
YourUserHome).
Double-click Normal to open it. Insert an endnote, change the
numbers
to
1,2,3. Then delete the endnote, and any accidental spaces or
text.
Save
Normal, and close it.

Create a new document (cmd-n). See if the default endnote is
1,2,3.

If that worked to change the default, try this on your problem
doc:
Copy
everything except the last paragraph mark into a new default
doc.
Either
hit
¶ on the standard toolbar to view paragraph marks, or use cmd-a
to
Select
All, shift-arrow to move the selection back one invisible
paragraph
mark,
and cmd-c to copy. Save the new doc.

I'm totally guessing, but it's possible that if the default is
set to
1,2,3,
it won't revert when you email it. It's also possible that the
last
paragraph mark carried some corruption that was causing the
problem.

You might email the known-problem doc to yourself to see if it
reverts
on
your own machine. If it does, then you can test your own
second doc.

Hope something there helps,
Daiya


On 8/16/06 7:03 AM, "(e-mail address removed)" wrote:

Hi,
I'm currently using OS 10.3.9 with Word 2004 v. 11.4. I have
composed
a large document that contains endnotes. For endnote
reference
numbers, Word defaults at roman numerals, but I tell it to use
arabic
numbers instead. When I email my document as a Word
attachment to
others and they open it, the endnote reference numbers have
all
reverted to roman numerals. Help please! I need the
reference
numbers
to stay in arabic numbers, as I've formatted and saved them.

While I'm at it, is there a way to change the default so that
the
endnote reference numbers start off as arabic?
Thanks so much for any help!
Karen



--

Please reply to the newsgroup to maintain the thread. Please do
not
email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical
Writer
Sydney, Australia +61 (0) 4 1209 1410


--

Please reply to the newsgroup to maintain the thread. Please do not
email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical
Writer
Sydney, Australia +61 (0) 4 1209 1410


--

Please reply to the newsgroup to maintain the thread. Please do not
email
me unless I ask you to.

John McGhie <[email protected]>
Microsoft MVP, Word and Word for Macintosh. Consultant Technical
Writer
Sydney, Australia +61 (0) 4 1209 1410
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top