filename is too long or contains illegal caracters


T

Ted

When I try to Publish to the web using Publisher 2007 on Vista, , I get the
message saying: "the filename you have entered is too long or contains
illegal characters...". The URL I use is "http://confluencelions.org" (I
also tried "http//www.confluencelions.org" which is the format that is shown
in the Publisher help text for "Prepare, publish, and maintain your publisher
Web site"). I use exactly the same URL in Publisher 2007 on my older
computer with XP and everthing works fine. Is there a problem with Pubisher
on Vista?

I use Frontpage extensions on my web host and I made sure my dial-up network
connection is working fine.
 
Ad

Advertisements

D

DavidF

Ted,

Uploading has changed a bit with Vista and IE7. Both FTP and HTTP uploading
protocol has changed.

As per the article you quoted: Prepare, publish, and maintain your Publisher
Web site:
http://office.microsoft.com/en-us/publisher/HA100947601033.aspx
There is a section about how you Publish changes to your site, and give two
sets of directions at the bottom of the article:

In Windows Vista:
On the File menu, click Publish to the Web.
In the Publish to the Web dialog box, in the navigation pane, click
COMPUTER.
In the file list, double-click the shortcut to the folder on the Web server
or network server where you published your Web site.
Double-click the folder where you want to save the file.
In the File name box, type the name of the file you are updating, and then
click Save.


In Windows XP:
On the File menu, click Publish to the Web.
In the Publish to the Web dialog box, click My NETWORK PLACES.
Double-click the shortcut to the folder on the Web server or network server
where you published your Web site.
Double-click the folder where you want to save the file.
In the File name box, type the name of the file you are updating, and then
click Save.


Note the difference in XP...Click "Computer" vs "My Network Places". Try the
different approach and see if that helps.

DavidF
 
T

Ted

David, thanks for your reply! In my XP computer, the shortcut to my web
server is in My Network Places and when I select it and click save, I do get
the logon screen for my web server. In my Vista computer, there are no
shortcuts in Computer or anywhere else that I can find. How can I set up the
shortcut?
 
D

DavidF

Ted,

I don't have Vista installed so can't test this myself, but here are some
instructions posted some time ago by Brelade. He is talking about ftp, but
the same is true for http:

"To Publish to Web with Vista

You need to Add a network location by Open Computer first before you try and
save.

1. Open Computer from start menu.
2. Right-click an empty spot main window paine. Choose "Add a Network
Location".
4. Follow on screen prompts
5. Secify the location of your website ensure you input correct format
(ftp://yoursite.co.uk)
6. Specify a user Name &Password if required. Uncheck log on anonymously &
input you logon details (ensure it is the correct logon details supplied
from
web host)
7. Wizzard will give you new shortcut a name. (You can change this if you
prefer)
8. The Wizard will create a shortcut to your account in Computer,
9. Your sever folder will open in a list on the left small paine / large
icons in the main right paine.
10. Close Computer file.
11. Open Publisher & create & save in normal way.
12. Select Publish to web icon in top left menu bar or file Publish to web.
13. Vista will open computer listing all your normal folders.
14. Scroll down to find your shortcut address to your site.
15. Right click choose login as.
16. Small window will apear asking you to input User name / Password (check
save password for furture login's).
17. your web folders will appear in main window.
18. In bottom menu bar you will see file name: / Save as type.
19. File name: index
20. Save as type: Web Page, Filtered.(If not there use drop down menu arrow
to select).
21. index.htm already exists. Do you want to replace it. ("YES").
22. Working "Publishing HTML Files" will appear on your web page. (Do not
select anything on the page be patient or programe wil frezze and fail to
respond.)
23. After a while, depending how long to upload. (still remain patient.)
24. Saving as: ftp://yoursite.co.uk will appear.
25. Once this disappers your upload is complete.

For future saves follow steps 11. to 25.

Happy Vista uploads with MS Publisher.

Cheers.
--
brelade"

You will of course want to use http://yoursite.com instead of the ftp site.
Here is a link to some more information about mapping a network drive:

http://compnetworking.about.com/od/windowsxpnetworking/ht/mapnetworkdrive.htm

And

http://www.vista4beginners.com/Map-Network-Drive

If you find one procedure better than another, please post back for the
benefit of others.

DavidF
 
T

Ted

David,

Per you suggestion, I tried to Add a Network Location in "Computer", but I
get an error window saying " "The folder you entered does not appear to be
valid. Please choose another" Why is it complaining about a folder? I did
not enter a folder. I entered an internet address. I tried entereing many
variations of the address and got the same error.

On my XP computer, I use the same URL and the same shared internet
connection and everything works OK. The only difference is Vista. Do you
know if anyone else has been able to publish to the web using Publisher 2007
on Vista?

Can you suggest anything else or anywhere else that I might be able to get
help on this problem. I am getting desperate!
 
D

DavidF

I am sorry but I don't have Vista installed, so can't work out specifics for
you. It is Vista and IE 7 that is creating the problems. You had IE6 in XP.
The best I can suggest at this point is to google "map a network drive" and
read other articles about how to do that, and perhaps one of them will give
you the solution. That is how I found the links I provided. Or, perhaps
"http uploading and Vista" as a google search.

And if Rob sees the ping, maybe he can talk more knowledgeably about how to
use http uploading protocol with Vista and IE7...

I'll keep looking but....

DavidF
 
D

DavidF

One thought...how exactly did your write the path? Did you use a forward
slash at the end, such as this? http://www.yourdomain.com/

Where is your root directory? Do you upload to a particular folder on your
server? If so, try incorporating it into the path to the root. example:
http://www.yourdomain.com/publicfolder/

Just thought it worth suggesting that you double check that you wrote the
paths correctly...

DavidF
 
T

Ted

David,

Thanks!

I have tried both variations of the URL (plus many others) but I get the
same error. When I ADD NETWORK LOCATION (within COMPUTER), I get "folder
does not appear valid"; When I PUBLISH TO WEB (withing PUBLISHER) I get "the
filename you have entered is too long or contains illegal characters".

Does Microsoft have any support site that I could use to get help?
 
D

DavidF

Try the instructions for "mapping a network drive", and/or google for more.
That is different than adding a network location. I realize that this is
different than what brelade suggested.

Your guess is as good as mine as to where on the MSFT site there is any
support for this. I haven't found anything.

Though your FPSE seemed to be ok when I tested your site for them, you might
try uninstalling them on your server, and then reinstalling them. FPSE can
become corrupt. Did you look in the support section of your host to see if
they are offering any instructions on how to do http uploading with Vista
and IE7? It might be under instructions for uploading from FrontPage. You
might also talk to the support people at your web host and see if they have
any suggestions. They aren't likely to know much about Publisher, but should
be able to tell you about how uploading with FPSE from FrontPage has changed
with IE7 and Vista. And you might post the question in the FrontPage
newsgroup, but be aware that they are likely to flame you for using
Publisher. Just ask about the differences of HTTP uploading protocol with
Vista and IE7 with FP, and that should also apply to Publisher.

Hopefully someone else will jump in here with some advice. I will continue
to look for an answer in the meantime, and of course if you figure it out,
let us know. Sorry I am not more help.

DavidF
 
T

Ted

David,

First let me answer your earlier post. I do know that FPSE is fine on my
server because I can publish the same web site over the same connection using
my older XP computer. I will call them however and see if they are aware of
any problems uploading from Vista using FPSE from Frontpage (they have in the
past told me they don't know anything about Publisher).

Second, you have been a BIG HELP and I appreciate all the time you have been
taking to look into this for me! I am so greatful that you are finding these
related problems.

Third, the last post from you does sound very similar to the problem I am
having. I am a little concerned about making the registry change that they
suggest. I am concerned that it may only apply to the other products, not
necesarily to Publisher. Also, it is hard for me to understand how Microsoft
would not know about this issue since it is so basic to Publisher and
especially FrontPage. But, I will probably try this change since I have no
other solution at this time. I will continue to look other places.
 
Ad

Advertisements

D

DavidF

Ted,

Thanks for ruling out FPSE as the potential problem.

You are welcome, and I appreciate your assistance and feedback. I am sure
others will have this same problem, and it would be great to have a known
fix.

I appreciate your reluctance to try the registry fix...scares me too, but it
sure sounded like the same error, and happening when trying to using HTTP
uploading.

By the way, which version of Vista are you using?

DavidF
 
T

Ted

David

I have been working with Microsoft Publisher Support about this problem and
they gave me a download (see article KB907306) that solves part of the
problem. With this download I can "Add a Network Location' from "Computer"
and then after clicking on the icon and entering my logon information , I
can drag and drop my files onto the web site. I can not, however, publish my
web site directly from Publisher. They supposedly are woking on this part of
the problem. I'll let you know when I get further information from them.
Here is the link:
http://www.microsoft.com/downloads/details.aspx?familyid=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
 
D

DavidF

Ted,

Thanks so much for the information. I ran across that KB, and almost posted
it to your attention, but when I followed the link at the bottom of that KB
that described the problem it was supposed to fix, the article was dated
2005. That left me thinking it probably wasn't relevant. Glad I was wrong.

One question...when you create that "network location" in "computer" is that
an ftp connection or a http? Does it work with FPSE? When you upload this
way, does it break your forms?

Please do post any follow up information you might get. It would be greatly
appreciated.

DavidF
 
T

Ted

David,
It is an http connection and it does work with FPSE. Also, my web site does
include a form and it does work. Microsoft has not yet fixed the problem,
but they assured me they are aware of the problem and some others are having
the same problem.

Ted
 
D

DavidF

Thanks for the update Ted. Hopefully we will get some help with this from
MSFT.

DavidF
 
J

johny log

Hello guys,

Do you encounter errors while deleting files in Windows? I'm here to provide a solution. I've been reading several threads on this topic on different forums where computer users were asking about this popular error "The filename you specified is not valid or too long".

My research helped me to find a tool for you guys.

Its LONG PATH TOOL, a very easy to run but highly powerful software.

Follow the link to read more about this error.

http://www.longpathtool.com
 
J

johny log

Hello guys,

Do you encounter errors while deleting files in Windows? I'm here to provide a solution. I've been reading several threads on this topic on different forums where computer users were asking about this popular error "The filename you specified is not valid or too long".

My research helped me to find a tool for you guys.

Its LONG PATH TOOL, a very easy to run but highly powerful software.

Follow the link to read more about this error.

http://www.longpathtool.com
 
J

johny log

Hello guys,

Do you encounter errors while deleting files in Windows? I'm here to provide a solution. I've been reading several threads on this topic on different forums where computer users were asking about this popular error "The filename you specified is not valid or too long".

My research helped me to find a tool for you guys.

Its LONG PATH TOOL, a very easy to run but highly powerful software.

Follow the link to read more about this error.

http://www.longpathtool.com
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top