Grid Lines Do Not Appear Even When Grid is Selected


S

SSi308

I changed the drawing scale and now the grid does not show on my drawing even
though Grid is check marked on the View menu.

How do I get it back.
 
Ad

Advertisements

P

Paul Herber

I changed the drawing scale and now the grid does not show on my drawing even
though Grid is check marked on the View menu.

How do I get it back.

menu Tools -> Ruler and Grid
Check that the grid spacing is set to Fine and the spacing and density
are set to 0.
 
S

SSi308

Grid Spacing is set to Fine and the Minimum spacing and Grid origin is set to
Zero. I do not see a density setting.
 
S

SSi308

In your original reply your instructions were:
menu Tools -> Ruler and Grid
Check that the grid spacing is set to Fine and the spacing and density
are set to 0.


Any other suggestions?
 
B

Barb Way

That's weird. You could also check to see if the drawing environment
colors, like Page color, have been changed. If the page color is changed,
the grid color will not change to maintain contrast.

Check under Tools > Options > Advanced > Color Settings.
For Drawing Window, if the color currently set is gray, try changing to
White or even Black.

As a real last resort, you could export your Application settings from the
registry, and delete those settings to see if you can revert the
environment back to normal. Be sure to set all settings into the registry
first. Follow these steps:
1. Go to Tools > Options > Advanced
2. Check the box "Put all settings in Windows registry", click OK
3. Close Visio.
4. Restart Visio and close again. (This forces a write to the registry if
the setting was changed)
5. Open the Registry editor.
6. Locate the key <HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Visio>.
(For Visio 2007, change version to 11.0 for Visio 2003)
7. Right-click the Visio key, and chose Export.
8. Select a file name and Save
9. Once the export is complete, delete the Visio key.
10. Launch Visio.

Let us know if this helps!


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------

In your original reply your instructions were:
menu Tools -> Ruler and Grid
Check that the grid spacing is set to Fine and the spacing and density
are set to 0.


Any other suggestions?
 
Ad

Advertisements

P

Paul Herber

In your original reply your instructions were:
menu Tools -> Ruler and Grid
Check that the grid spacing is set to Fine and the spacing and density
are set to 0.

Yes, I know, the dialog says origin, where I get the idea of density
from I know not!
 
S

SSi308

Sorry, I misunderstood. Thought you were questioning where I got it from.
Thanks.
 
S

SSi308

When navigating the registry, I get to <HKEY_CURRENT_USER\Software\Microsoft\
there is no Office key.

Barb Way said:
That's weird. You could also check to see if the drawing environment
colors, like Page color, have been changed. If the page color is changed,
the grid color will not change to maintain contrast.

Check under Tools > Options > Advanced > Color Settings.
For Drawing Window, if the color currently set is gray, try changing to
White or even Black.

As a real last resort, you could export your Application settings from the
registry, and delete those settings to see if you can revert the
environment back to normal. Be sure to set all settings into the registry
first. Follow these steps:
1. Go to Tools > Options > Advanced
2. Check the box "Put all settings in Windows registry", click OK
3. Close Visio.
4. Restart Visio and close again. (This forces a write to the registry if
the setting was changed)
5. Open the Registry editor.
6. Locate the key <HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Visio>.
(For Visio 2007, change version to 11.0 for Visio 2003)
7. Right-click the Visio key, and chose Export.
8. Select a file name and Save
9. Once the export is complete, delete the Visio key.
10. Launch Visio.

Let us know if this helps!


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------

In your original reply your instructions were:
menu Tools -> Ruler and Grid
Check that the grid spacing is set to Fine and the spacing and density
are set to 0.


Any other suggestions?

Paul Herber said:
Where did I get density from?
 
P

Paul Herber

When navigating the registry, I get to <HKEY_CURRENT_USER\Software\Microsoft\

Is this an early version of Visio? 2000/2002?
If so then try
HKEY_CURRENT_USER\Software\Microsoft\Visio
 
S

SSi308

I am running Visio Pro 2003 sp3
(I checked for the key listed below anyway and it is not there.)
 
Ad

Advertisements

P

Paul Herber

I am running Visio Pro 2003 sp3
(I checked for the key listed below anyway and it is not there.)

Sorry, I'll have to leave any explanation of that to someone else ...
 
B

Barb Way

For Visio 2003 you should definitely see the Office key under
<HKEY_CURRENT_USER\Software\Microsoft\>, even when the version installed is
the Visio for Enterprise Architects (VEA) version bundled with Visual
Studio, this is our registry location.
Even without forcing the complete registry write action, there is a subset
stored at that location for Visio when it is installed properly.
Make sure you are looking under HKEY_CURRENT USER, not HKEY_USERS or
HKEY_LOCAL_MACHINE in REGEDIT.

Next, try a new user profile on the same machine to see if you see the same
thing. If not - then it may be something broken in the user profile, and
you may want to move what you need from the old to the new.

Next, check in the Control Panel. Do you see Visio 2003 listed under
Installed Programs in add/remove programs? Is it possible that you are
running a virtualized instance of Visio using something like Softgrid
application virtualization? If so, I am not sure where the keys would be.

As a total last resort, you can completely remove all customizations in the
Visio instance and blast it back to installed state - but this is a hard
reset, as if installing Visio on a new computer - so use it only as last
resort. Also - if you determine you are running in a software
virtualization mode, I am not sure what (if any) benefit this will have.
To repair / reset completely, use these steps:
Launch Visio
Under the Help menu, select 'Detect and Repair'
When prompted, check both optional boxes, which will restore shortcuts
and discard customized settings, and click Start.
This should completely reset Visio to a 'new install' state. It will
remove most recently used file lists, recent templates, command bar
customizations, and everything else that user's can customize, and once you
click Start it moves pretty quickly! Once thing you might want to do is
back up your user profile first.


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------

I am running Visio Pro 2003 sp3
(I checked for the key listed below anyway and it is not there.)

Sorry, I'll have to leave any explanation of that to someone else ...
 
Ad

Advertisements

Joined
Aug 13, 2020
Messages
1
Reaction score
0
I have been having this issue for awhile now and I tried everything in this forum and nothing worked. I finally realized when visio opened on my actual laptop, that I could see the grid lines, but when I moved it to my secondary monitor, I could not see them. I adjusted the contrast on my extra monitors and then I could see the grid lines.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top