How do I keep styles in a word table when copying and pasting


A

Andy

I have two tables with many different cells that are identical in size.

One table (source table) contains the text that I need to put into the
second table (destination table). The destination table contains the styles
/ formatting that I want to use. The source table contains incorrect
formatting that I do not want to import into the destination document. When
I copy and paste the source table cells / contents to the destination table
it retains the source table formatting. I do not want this to happen.
Normally when I paste into a document a button comes up that allows me to
retain the destination table formatting. This does not happen when I paste
to more than one cell in a table at a time. If I paste as unformatted text,
all formatting / styles are lost and all formatting becomes "normal".

Is there some way to copy and paste more than one cell at a time from one
table to another and retain the destination formatting / is there some work
around for this deficiency in word? Doing so will save me many hours of
repetitive and mind numbing copying and pasting.

Thanks.

-Andy
 
Ad

Advertisements

D

DeanH

This may help.
Tools, Options, Edit, check the "show paste options buttons" box. This will
give you options when you paste whethe rto keep source formating or
destination formating.
Also you can try the "Smart cut and paste" box and in the Settings uncheck
the "Adjust table formatting and alignment on paste".
I tend not to have either of these options checked anyway so not sure if
this will solve the problem you are seeing.
DeanH
 
A

Andy

Thanks for your help, but these suggestions do not work. The option to use
the destination formatting does not come up when pasting into tables (whether
enabled or not). Does anyone know how to turn off importing styles or force
word to use the destination styles when pasting into a table?
 
P

PamC via OfficeKB.com

If you use paste special and unformatted text, the pasted text should take on
the destination style.

PamC

Thanks for your help, but these suggestions do not work. The option to use
the destination formatting does not come up when pasting into tables (whether
enabled or not). Does anyone know how to turn off importing styles or force
word to use the destination styles when pasting into a table?
This may help.
Tools, Options, Edit, check the "show paste options buttons" box. This will
[quoted text clipped - 27 lines]
 
A

Andy

Thanks for your help, however this does not work. Text is inserted as normal
style not destination style.

PamC via OfficeKB.com said:
If you use paste special and unformatted text, the pasted text should take on
the destination style.

PamC

Thanks for your help, but these suggestions do not work. The option to use
the destination formatting does not come up when pasting into tables (whether
enabled or not). Does anyone know how to turn off importing styles or force
word to use the destination styles when pasting into a table?
This may help.
Tools, Options, Edit, check the "show paste options buttons" box. This will
[quoted text clipped - 27 lines]
 
P

PamC via OfficeKB.com

Andy,

Check to make sure the destination style is what you think it is. I use
paste as unformatted text every day, and the pasted text always takes on the
style that is active at the paste site. Unless you missed telling us some
important difference in your situation, it should work.

Pam

Thanks for your help, however this does not work. Text is inserted as normal
style not destination style.
If you use paste special and unformatted text, the pasted text should take on
the destination style.
[quoted text clipped - 11 lines]
 
Ad

Advertisements

A

Andy

Pam-

The pasting unformatted text option does not work when pasting into multiple
cells in a table. Cells have to be pasted one at a time in order for the
text to take on the destination style.

I'd be more than happy to send the file to someone to see if they can get it
to work but it does not work for me. I have Word 2003 with all updates. If
this is supposed to work it should probably be brought to microsoft's
attention because it is not working for me.

Thanks

PamC via OfficeKB.com said:
Andy,

Check to make sure the destination style is what you think it is. I use
paste as unformatted text every day, and the pasted text always takes on the
style that is active at the paste site. Unless you missed telling us some
important difference in your situation, it should work.

Pam

Thanks for your help, however this does not work. Text is inserted as normal
style not destination style.
If you use paste special and unformatted text, the pasted text should take on
the destination style.
[quoted text clipped - 11 lines]
 
Ad

Advertisements

J

Janet A. Thompson

Is your destination table cell style Normal? If you make your source table
cell style Normal, the same name. does it work?
--
Janet A.


Andy said:
Pam-

The pasting unformatted text option does not work when pasting into multiple
cells in a table. Cells have to be pasted one at a time in order for the
text to take on the destination style.

I'd be more than happy to send the file to someone to see if they can get it
to work but it does not work for me. I have Word 2003 with all updates. If
this is supposed to work it should probably be brought to microsoft's
attention because it is not working for me.

Thanks

PamC via OfficeKB.com said:
Andy,

Check to make sure the destination style is what you think it is. I use
paste as unformatted text every day, and the pasted text always takes on the
style that is active at the paste site. Unless you missed telling us some
important difference in your situation, it should work.

Pam

Thanks for your help, however this does not work. Text is inserted as normal
style not destination style.

If you use paste special and unformatted text, the pasted text should take on
the destination style.
[quoted text clipped - 11 lines]

-Andy
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top