Hyperlink does not show as hand symbol


S

Skafti

In Visio 2003, when I create a hyperlink it does not show as hand symbol in a
Web page. A message repeating the name of the shape and the text "Click to
follow hyperlink" is displayed. lWeb pages that I made 3 years ago, also from
Visio 2003, do show the hand. When I open the old drawings and save them, the
hand symbol is replaced with the name of the shape and the "Click to follow
hyperlink" message.
How can I "get the hand back"?
Best regards
Skafti
 
Ad

Advertisements

B

Barb Way

Unfortunately, it appears we have neglected to emit the pointer style for
links in the VML output. The good news is that it doesn't happen if you
change the Save As Web Page option to output using GIF/SVG/PNG or other
graphic outputs, it only occurs with VML.

The problem is found in the file "vml_1.htm" (found in the direcroty hive
of files). If you search for each Href tag and add the text as shown
below, each linked shape will then have a hand pointer when you mouse over.

This line snip, for instance:
<v:shape type="#VISSHAPE"
origHref="http://www.microsoft.com/en/us/default.aspx" tabindex="1"

... Should be:
<v:shape type="#VISSHAPE"
origHref="http://www.microsoft.com/en/us/default.aspx" style="cursor:
pointer;" tabindex="1"

This does not occur in Visio 2007 or in the new version of Visio under
development. Since Visio 2003 has recently released Service Pack 3, this
issue will not be addressed unless/until a future service pack is created.
The work around would be to change the output type to one of the alternates:
File | Save as Web Page
Set output name and location, click the Publish button
On the Advanced tab, under Output Formats, select an option other than
VML.

I apologize for any inconvenience this causes.


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------
Subject: Hyperlink does not show as hand symbol

In Visio 2003, when I create a hyperlink it does not show as hand symbol in
a
Web page. A message repeating the name of the shape and the text "Click to
follow hyperlink" is displayed. lWeb pages that I made 3 years ago, also
from
Visio 2003, do show the hand. When I open the old drawings and save them,
the
hand symbol is replaced with the name of the shape and the "Click to follow
hyperlink" message.
How can I "get the hand back"?
Best regards
Skafti
 
J

jetshy

Hi

Thanks a lot, for the info, but could someone please release a patch/update
to fix the issue, As we use 2003 coz the relative hyper link feature doesn't
work in Visio 2007.

Thanks
Tej

Barb Way said:
Unfortunately, it appears we have neglected to emit the pointer style for
links in the VML output. The good news is that it doesn't happen if you
change the Save As Web Page option to output using GIF/SVG/PNG or other
graphic outputs, it only occurs with VML.

The problem is found in the file "vml_1.htm" (found in the direcroty hive
of files). If you search for each Href tag and add the text as shown
below, each linked shape will then have a hand pointer when you mouse over.

This line snip, for instance:
<v:shape type="#VISSHAPE"
origHref="http://www.microsoft.com/en/us/default.aspx" tabindex="1"

... Should be:
<v:shape type="#VISSHAPE"
origHref="http://www.microsoft.com/en/us/default.aspx" style="cursor:
pointer;" tabindex="1"

This does not occur in Visio 2007 or in the new version of Visio under
development. Since Visio 2003 has recently released Service Pack 3, this
issue will not be addressed unless/until a future service pack is created.
The work around would be to change the output type to one of the alternates:
File | Save as Web Page
Set output name and location, click the Publish button
On the Advanced tab, under Output Formats, select an option other than
VML.

I apologize for any inconvenience this causes.


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------
Subject: Hyperlink does not show as hand symbol

In Visio 2003, when I create a hyperlink it does not show as hand symbol in
a
Web page. A message repeating the name of the shape and the text "Click to
follow hyperlink" is displayed. lWeb pages that I made 3 years ago, also
from
Visio 2003, do show the hand. When I open the old drawings and save them,
the
hand symbol is replaced with the name of the shape and the "Click to follow
hyperlink" message.
How can I "get the hand back"?
Best regards
Skafti
 
B

Barb Way

Hi Tej,

I logged the issue, but since Visio 2003 SP3 released fairly recently, any
fix will not happen until and unless a new service pack is released. If
there is a future service pack, this issue will be triaged along with other
known issues for potential fixes.


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------
Thread-Topic: Hyperlink does not show as hand symbol

Hi

Thanks a lot, for the info, but could someone please release a patch/update
to fix the issue, As we use 2003 coz the relative hyper link feature
doesn't
work in Visio 2007.

Thanks
Tej

Barb Way said:
Unfortunately, it appears we have neglected to emit the pointer style for
links in the VML output. The good news is that it doesn't happen if you
change the Save As Web Page option to output using GIF/SVG/PNG or other
graphic outputs, it only occurs with VML.

The problem is found in the file "vml_1.htm" (found in the direcroty hive
of files). If you search for each Href tag and add the text as shown
below, each linked shape will then have a hand pointer when you mouse over.

This line snip, for instance:
<v:shape type="#VISSHAPE"
origHref="http://www.microsoft.com/en/us/default.aspx" tabindex="1"

... Should be:
<v:shape type="#VISSHAPE"
origHref="http://www.microsoft.com/en/us/default.aspx" style="cursor:
pointer;" tabindex="1"

This does not occur in Visio 2007 or in the new version of Visio under
development. Since Visio 2003 has recently released Service Pack 3, this
issue will not be addressed unless/until a future service pack is created.
The work around would be to change the output type to one of the alternates:
File | Save as Web Page
Set output name and location, click the Publish button
On the Advanced tab, under Output Formats, select an option other
than
VML.

I apologize for any inconvenience this causes.


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------
Subject: Hyperlink does not show as hand symbol

In Visio 2003, when I create a hyperlink it does not show as hand symbol in
a
Web page. A message repeating the name of the shape and the text "Click to
follow hyperlink" is displayed. lWeb pages that I made 3 years ago, also
from
Visio 2003, do show the hand. When I open the old drawings and save them,
the
hand symbol is replaced with the name of the shape and the "Click to follow
hyperlink" message.
How can I "get the hand back"?
Best regards
Skafti
 
Ad

Advertisements

J

JackMantis

Is MicroSoft ever going to create something that does not have to be patched
or re-written?

"oops, we forgot the hand..."
"oops, no more relative links..."

:-\
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top