Importing EPS file into Word 2007

Discussion in 'Word Graphics' started by Rich Quist, Dec 10, 2008.

  1. Rich Quist

    Rich Quist Guest

    The "insert EPS file" functionality in Word 2007 seems to have been updated
    from previous releases, and isn't displaying or printing the content of some
    encapsulated postscript (eps) files properly.

    The attached eps file, when inserted into Word 2007 (click on Insert tab,
    click on Picture), displays and prints with a gap in the blue line on the
    left-hand side of the plot. This gap is not present in Word 2003 or in other
    postscript viewers such as ghostview. I've also seen instances where the
    printed page just displays a message indicating a syntax error and doesn't
    print the picture at all.

    I've tried searching the Microsoft web site but haven't been able to find
    anything about this kind of issue. Has anyone come across this and/or know if
    there are any options available to control how the .eps files are imported?

    Thanks in advance.
     
    Rich Quist, Dec 10, 2008
    #1
    1. Advertisements

  2. Rich Quist

    Rich Quist Guest

    I'd still appreciate hearing suggestions on this.

    Thanks
     
    Rich Quist, Dec 23, 2008
    #2
    1. Advertisements

  3. Hi Rich,

    With the EPS file you posted I get the same gap in both Word 2003 and Word 2007 when using Insert=>Picture, but not in other
    viewers, such as http://irfanview.com There can be variations based on which EPSImp32.FLT Office Graphic Filter version is in use.
    With the filter Word generally does not use a preview picture (if any) stored in the EPS file, but renders from its own. I didn't
    see anything on a quick look at the Postscript code of the MatLab generated graph.

    Do you also get the gap when printing?


    ============
    The "insert EPS file" functionality in Word 2007 seems to have been updated
    from previous releases, and isn't displaying or printing the content of some
    encapsulated postscript (eps) files properly.

    The attached eps file, when inserted into Word 2007 (click on Insert tab,
    click on Picture), displays and prints with a gap in the blue line on the
    left-hand side of the plot. This gap is not present in Word 2003 or in other
    postscript viewers such as ghostview. I've also seen instances where the
    printed page just displays a message indicating a syntax error and doesn't
    print the picture at all.

    I've tried searching the Microsoft web site but haven't been able to find
    anything about this kind of issue. Has anyone come across this and/or know if
    there are any options available to control how the .eps files are imported?

    Thanks in advance.>>
    --

    Bob Buckland ?:)
    MS Office System Products MVP

    *Courtesy is not expensive and can pay big dividends*
     
    Bob Buckland ?:-\), Dec 30, 2008
    #3
  4. Rich Quist

    Rich Quist Guest

    Bob,

    Thanks for taking the time to look at this.

    I do get the gap when printing from MS Word, but not when printing from other
    apps (ghostview, Adobe Illustrator)

    I searched my hard drive and found the graphics filters in C:\Program
    Files\Common Files\Microsoft Shared\GRPHFLT. The eps filter is dated
    08/23/2007 and the version properties tab shows (among other properties)
    File Version: 2006.1200.6211.1000
    Product Version: 2006.1200.6211.1000
    Product Name: 2007 Microsoft Office System
    That appears to be the latest one that Office ships with


    Rich
     
    Rich Quist, Dec 30, 2008
    #4
  5. I've found the workaround.

    I have 2003 Office
    There is a file which is responsible for filtering EPS while inserting it into Word document:

    C:\Program Files (x86)\Common Files\microsoft shared\GRPHFLT\EPSIMP32.FLT

    The version I had was dated to ?2003? .

    I've replaced it with another version dated 2007 and I can see all imported EPS images now!

    Here is a link to this(working) filter on my DropBox
    http://dl.dropbox.com/u/1857399/EPSIMP32.FLT
     
    Yaroslav Fedorina, Mar 17, 2011
    #5
  6. I've found the workaround.

    I have 2003 Office
    There is a file which is responsible for filtering EPS while inserting it into Word document:

    C:\Program Files (x86)\Common Files\microsoft shared\GRPHFLT\EPSIMP32.FLT

    The version I had was dated to ?2003? .

    I've replaced it with another version dated 2007 and I can see all imported EPS images now!

    Here is a link to this(working) filter on my DropBox
    http://dl.dropbox.com/u/1857399/EPSIMP32.FLT
     
    Yaroslav Fedorina, Mar 17, 2011
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.