Mouse Not Working, Can't move insertion point or select text Word


K

k.c.s.

Symptoms:

1) The common fixes from the past do not resolve this problem on Windows 7
64-bit.

2) When you open an existing Word document you are able to use the mouse as
usual to move the insertion point cursor to different sections of the
document, to select objects (like pictures) within the document, and to
highlight existing text as expected. As soon as you type anything new
anywhere in the document the mouse can no longer be used to move the
insertion point to another location in the document nor can it select text or
objects. The arrow and shift keys still allow you to move around the
document and select objects.

3) When you create a new document you are able to type normally and use the
Enter key to add text to the Word document. As soon as you type anything in
the document the mouse can no longer be used to move the insertion point to
another location in the document nor can it select text or objects. The
arrow and shift keys still allow you to move around the document and select
objects.

4) You CAN use the mouse to select Word menus and buttons on the ribbon bar
but you cannot use the mouse on or inside the Word document itself once the
condition occurs after typing begins. The mouse works fine and as expected
in Excel and every other application.

5) As soon as ANY open Word document is impacted by the "mouse stopped
working" problem, all other open Word documents can't use the mouse either
until Word is closed and you start the tests over again.


Solutions that did not work for me:

Similar symptoms have been reported by others using Word 2007 and 2003 on
Windows 7, Vista, and XP but I have not found an acceptable solution to this
problem with this system configuration. It seems related to some kind of UAC
or permission problem or is 64-bit specific but I am not certain.

I have already tried the following:

- Rerun Office Suite 2007 SP2 to confirm it was installed.

- Tried (twice) to rename the original,
"HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Data" registry key as
suggested in these posts. The new Data key gets created by Word and new
values are added to the registry key but problem remains.
http://support.microsoft.com/default.aspx/kb/921541

http://www.microsoft.com/office/com...8e5f&mid=16025683-dff2-4ad9-9fc7-0144fee5f43c
http://social.answers.microsoft.com/Forums/en/vistawu/thread/c64e9c05-2bc4-4837-aec1-fb675120403b

- Other posts out there blame various Word Add-ins for the problem and have
had success disabling or removing them.
http://www.itwriting.com/blog/140-annoying-word-2007-problem-cant-select-text.html

I only had 3 Add-ins showing as active, all from Microsoft. Two Visual
Studio Tools for Office COM Add-ins and one Smart Tag "Person Name" add in.
I ran Word as admin so I could disable both of the COM Add-ins. I renamed
the FNAME.DLL file so the "Person Name" Add-in would not load because the
Word GUI had all Smart Tag options dimmed and wouldn't let me uncheck that
Add-in from the UI. I restarted Win, launched Word, and it showed no Active
Application or Document Related Add-ins. No luck, mouse problem still
present with all Add-ins removed.

Bad Workaround:

- The only way I have found to USUALLY get the mouse to behave as expected
and eliminate the problems described here is to force Word to "Run this
program as administratorâ€. I opened the properties of the "Microsoft Office
Word 2007" shortcut in the start menu, chose Compatibility tab, and chose
that option under privilege level. Without running Word as administrator I
have been unable to eliminate these mouse problems.

- Once you force Word to Run as admin, you now get the annoying warning
prompt from Windows that asks you if it is okay to run as admin every time
you start Word. This would be an almost tolerable workaround if all you ever
did was create brand new Word documents. If you want to work on an existing
Word document this solution isn't a good one, here is why:

1) If you want to open an existing Word document from either the Windows 7
recent jump list menu or by double-clicking a Word doc file, the delay caused
by the UAC prompt every time you start Word generates an error of, "There was
a problem sending the command to the program.", and the document you wanted
to open is not loaded into Word. You get the Word shell launched with no
document. The only way to open an existing document while running as admin
and getting the UAC prompt is to launch Word with no document or a new blank
document and then manually open the existing document you really wanted via
the Word menus.

2) As a temporary option I tried to disable User Account Control (UAC)
completely by telling it to NEVER notify me about anything. You would think
that this would allow you to run Word as admin without the delay caused by
the UAC prompt and then Word would open existing documents from the taskbar
or by double-clicking as desired. I did the required restart after disabling
UAC and confirmed that Word was still set to "run as admin". To my surprise,
when UAC is totally disabled and no longer prompts you for permission each
time you launch Word, the "run as admin" trick STOPS working. The existing
documents now load from the taskbar or by double-clicking as desired because
the UAC prompt delay is gone BUT the mouse problems come back!

3) I have no idea why "run as admin" ONLY works if UAC prompts you for
permission first and does NOT work if you tell it not to prompt you but that
is what is happening on my system. I am still looking for a better solution.


Anyone have any ideas?


System Info:
Windows 7 Ultimate 64-bit, RTM Version 6.1.7600
ThinkPad T61p (Lenovo) Laptop, 4GB RAM
Word 2007 (12.0.6504.5000) SP2 MSO (12.0.6425.1000) Part of Office Ultimate
2007.
Patched with all recommended updates for Windows/Office through
Windows/Microsoft Update as of this post date.
 
Ad

Advertisements

K

k.c.s.

**Update to the "Bad Workaround" section: I experience the EXACT same
behavior if I do NOT "run as admin" but instead tell the shortcut to Word to
run in "Windows XP SP3 compatibility mode". Everything described above acts
the same if I use either "run as admin" or "act like XP", this method ALSO
required UAC to prompt me in order for it to work. If I tell UAC to not
prompt me then the XP mode fails just like run as admin did. I am not sure
what "run as admin" and "XP compat" have in common when running with UAC
turned on but using either method results in the mouse working.

Also, the latest nVidia Video Driver for Windows 7 64-bit installed
(v8.16.11.8694), that version is in Windows Update and on Lenovo site.
 
J

jimm98y

I have exactly the same problem as you do, but in my case that problem
affects Word 2007 and Outlook 2007. Symptoms are the same as yours. In Word
text selection stops usually working after clicking at inserted equation or
saving my document. In Outlook it appears randomly when I'm typing new
message. Any help would be appreciated.
My configuration:
Lenovo ThinkPad T61
Windows 7 Ultimate x64 EN
Office 2007 Basic SP2 CZ
 
J

jimm98y

And I forgot - deleting the key Data in registry as suggested helps but only
for a while - after few minutes it's back. I have a clean install of Windows
7 (installed yesterday) and Office 2007 with all available updates installed.
Office diagnostics tool says everything is ok.
Strange thing is that when I ran regedit.exe and checked Word keys, the key
"Resiliency" was corrupted - I deleted it, then ran Word again and it worked
for about half an hour fine - then this mouse problem occured again. Maybe
that corrupted record was caused by bitlocker, because I was writing my
homework and disc encryption was running in background simultaneously.
 
W

Will

I have the same symptoms on my Thinkpad X61s with Windows 7
Professional, Office 2007 and all the latest updates from Microsoft as
well as Lenovo. None of the workarounds or fixes worked for me either
-- same results as reported above.

In addition, I can no longer click on weblinks in Outlook email
messages (which I always could do). I guess this suggests a UAC/
protect us from ourselves problem.

It seems we are all Thinkpad people -- is that a common link here?

Will
 
Ad

Advertisements

T

Terry Farrell

That's a symptom of a Word Data Key corruption - usually because Word has
been running when updates are installed.

Run Regedit and expand by double-clicking to the key below. With DATA
selected, press DELETE. Word will automatically recreate a new key when it
is restarted.

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Data

Symptoms of Data Key corruption include:

. The mouse does not work when you use Word.
. You cannot open a Word document from the Search window in Windows
Vista.
. You cannot open a Word document from Windows Desktop Search.
. Word crashes when you try to start or exit Word.
. Word crashes when you open the Open dialog box.
. Word crashes when you save a document.
. Word crashes when you close a document.

If you feel uncomfortable editing the registry yourself, Microsoft have a
fix that will do this for you.
http://support.microsoft.com/kb/940791 and press FixIt
 
T

Terry Farrell

To summarise this for everyone to save grappling through a long thread...

This is a bug with Password Manager part of the Lenovo Client Security
Solution (v. 8.30.0031.00). The solution is:

Click Start and type "password vault"
Click "Password Vault" (listed under Control Panel in the Start Menu)
Click "Set Preferences" in the menu
Under the General tab, uncheck "Enable hot keys"
Click OK
Close Password Vault
Log off (or reboot) and log back in

Watch out for an update to the Client Security Solution application from
Lenovo in the future if you would like to use hot keys.

Thanks for bringing this solution to our attention.
 
A

arif halim

Thank you very much,.
i try to find out the problem, and yes, you were right
the problem is with client security solution, password manager.



Terry Farrell wrote:

To summarise this for everyone to save grappling through a long thread...
06-Nov-09

To summarise this for everyone to save grappling through a long thread..

This is a bug with Password Manager part of the Lenovo Client Securit
Solution (v. 8.30.0031.00). The solution is

Click Start and type "password vault
Click "Password Vault" (listed under Control Panel in the Start Menu
Click "Set Preferences" in the men
Under the General tab, uncheck "Enable hot keys
Click O
Close Password Vaul
Log off (or reboot) and log back i

Watch out for an update to the Client Security Solution application fro
Lenovo in the future if you would like to use hot keys

Thanks for bringing this solution to our attention

-
Terry Farrell - MSWord MVP

Previous Posts In This Thread:

Mouse Not Working, Can't move insertion point or select text Word
Symptoms

1) The common fixes from the past do not resolve this problem on Windows
64-bit

2) When you open an existing Word document you are able to use the mouse a
usual to move the insertion point cursor to different sections of th
document, to select objects (like pictures) within the document, and t
highlight existing text as expected. As soon as you type anything ne
anywhere in the document the mouse can no longer be used to move th
insertion point to another location in the document nor can it select text o
objects. The arrow and shift keys still allow you to move around th
document and select objects

3) When you create a new document you are able to type normally and use th
Enter key to add text to the Word document. As soon as you type anything i
the document the mouse can no longer be used to move the insertion point t
another location in the document nor can it select text or objects. Th
arrow and shift keys still allow you to move around the document and selec
objects

4) You CAN use the mouse to select Word menus and buttons on the ribbon ba
but you cannot use the mouse on or inside the Word document itself once th
condition occurs after typing begins. The mouse works fine and as expecte
in Excel and every other application

5) As soon as ANY open Word document is impacted by the "mouse stoppe
working" problem, all other open Word documents cannot use the mouse eithe
until Word is closed and you start the tests over again

Solutions that did not work for me

Similar symptoms have been reported by others using Word 2007 and 2003 o
Windows 7, Vista, and XP but I have not found an acceptable solution to thi
problem with this system configuration. It seems related to some kind of UA
or permission problem or is 64-bit specific but I am not certain

I have already tried the following

- Rerun Office Suite 2007 SP2 to confirm it was installed

- Tried (twice) to rename the original
"HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Data" registry key a
suggested in these posts. The new Data key gets created by Word and ne
values are added to the registry key but problem remains
http://support.microsoft.com/default.aspx/kb/92154

http://www.microsoft.com/office/com...28e5f&mid=16025683-dff2-4ad9-9fc7-0144fee5f43
http://social.answers.microsoft.com/Forums/en/vistawu/thread/c64e9c05-2bc4-4837-aec1-fb675120403

- Other posts out there blame various Word Add-ins for the problem and hav
had success disabling or removing them
http://www.itwriting.com/blog/140-annoying-word-2007-problem-cant-select-text.htm

I only had 3 Add-ins showing as active, all from Microsoft. Two Visua
Studio Tools for Office COM Add-ins and one Smart Tag "Person Name" add in
I ran Word as admin so I could disable both of the COM Add-ins. I rename
the FNAME.DLL file so the "Person Name" Add-in would not load because th
Word GUI had all Smart Tag options dimmed and would not let me uncheck that
Add-in from the UI. I restarted Win, launched Word, and it showed no Active
Application or Document Related Add-ins. No luck, mouse problem still
present with all Add-ins removed.

Bad Workaround:

- The only way I have found to USUALLY get the mouse to behave as expected
and eliminate the problems described here is to force Word to "Run this
program as administrator???. I opened the properties of the "Microsoft Office
Word 2007" shortcut in the start menu, chose Compatibility tab, and chose
that option under privilege level. Without running Word as administrator I
have been unable to eliminate these mouse problems.

- Once you force Word to Run as admin, you now get the annoying warning
prompt from Windows that asks you if it is okay to run as admin every time
you start Word. This would be an almost tolerable workaround if all you ever
did was create brand new Word documents. If you want to work on an existing
Word document this solution is not a good one, here is why:

1) If you want to open an existing Word document from either the Windows 7
recent jump list menu or by double-clicking a Word doc file, the delay caused
by the UAC prompt every time you start Word generates an error of, "There was
a problem sending the command to the program.", and the document you wanted
to open is not loaded into Word. You get the Word shell launched with no
document. The only way to open an existing document while running as admin
and getting the UAC prompt is to launch Word with no document or a new blank
document and then manually open the existing document you really wanted via
the Word menus.

2) As a temporary option I tried to disable User Account Control (UAC)
completely by telling it to NEVER notify me about anything. You would think
that this would allow you to run Word as admin without the delay caused by
the UAC prompt and then Word would open existing documents from the taskbar
or by double-clicking as desired. I did the required restart after disabling
UAC and confirmed that Word was still set to "run as admin". To my surprise,
when UAC is totally disabled and no longer prompts you for permission each
time you launch Word, the "run as admin" trick STOPS working. The existing
documents now load from the taskbar or by double-clicking as desired because
the UAC prompt delay is gone BUT the mouse problems come back!

3) I have no idea why "run as admin" ONLY works if UAC prompts you for
permission first and does NOT work if you tell it not to prompt you but that

**Update to the "Bad Workaround" section: I experience the EXACT samebehavior
**Update to the "Bad Workaround" section: I experience the EXACT same
behavior if I do NOT "run as admin" but instead tell the shortcut to Word to
run in "Windows XP SP3 compatibility mode". Everything described above acts
the same if I use either "run as admin" or "act like XP", this method ALSO
required UAC to prompt me in order for it to work. If I tell UAC to not
prompt me then the XP mode fails just like run as admin did. I am not sure
what "run as admin" and "XP compat" have in common when running with UAC
turned on but using either method results in the mouse working.

Also, the latest nVidia Video Driver for Windows 7 64-bit installed
(v8.16.11.8694), that version is in Windows Update and on Lenovo site.

I have exactly the same problem as you do, but in my case that problemaffects
I have exactly the same problem as you do, but in my case that problem
affects Word 2007 and Outlook 2007. Symptoms are the same as yours. In Word
text selection stops usually working after clicking at inserted equation or
saving my document. In Outlook it appears randomly when I am typing new
message. Any help would be appreciated.
My configuration:
Lenovo ThinkPad T61
Windows 7 Ultimate x64 EN
Office 2007 Basic SP2 CZ

And I forgot - deleting the key Data in registry as suggested helps but
And I forgot - deleting the key Data in registry as suggested helps but only
for a while - after few minutes it is back. I have a clean install of Windows
7 (installed yesterday) and Office 2007 with all available updates installed.
Office diagnostics tool says everything is ok.
Strange thing is that when I ran regedit.exe and checked Word keys, the key
"Resiliency" was corrupted - I deleted it, then ran Word again and it worked
for about half an hour fine - then this mouse problem occured again. Maybe
that corrupted record was caused by bitlocker, because I was writing my
homework and disc encryption was running in background simultaneously.

There seem to be more people active on this topic over here:http://social.
There seem to be more people active on this topic over here:

http://social.answers.microsoft.com...s/thread/79e51132-b3af-476c-9226-bebca9a4382b

That's a symptom of a Word Data Key corruption - usually because Word hasbeen
That's a symptom of a Word Data Key corruption - usually because Word has
been running when updates are installed.

Run Regedit and expand by double-clicking to the key below. With DATA
selected, press DELETE. Word will automatically recreate a new key when it
is restarted.

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Data

Symptoms of Data Key corruption include:

.. The mouse does not work when you use Word.
.. You cannot open a Word document from the Search window in Windows
Vista.
.. You cannot open a Word document from Windows Desktop Search.
.. Word crashes when you try to start or exit Word.
.. Word crashes when you open the Open dialog box.
.. Word crashes when you save a document.
.. Word crashes when you close a document.

If you feel uncomfortable editing the registry yourself, Microsoft have a
fix that will do this for you.
http://support.microsoft.com/kb/940791 and press FixIt

--
Terry Farrell - MSWord MVP

I have the same symptoms on my Thinkpad X61s with Windows 7Professional,
I have the same symptoms on my Thinkpad X61s with Windows 7
Professional, Office 2007 and all the latest updates from Microsoft as
well as Lenovo. None of the workarounds or fixes worked for me either
-- same results as reported above.

In addition, I can no longer click on weblinks in Outlook email
messages (which I always could do). I guess this suggests a UAC/
protect us from ourselves problem.

It seems we are all Thinkpad people -- is that a common link here?

Will

The resolution to this problem is posted here:http://social.answers.microsoft.
The resolution to this problem is posted here:

http://social.answers.microsoft.com...s/thread/79e51132-b3af-476c-9226-bebca9a4382b

It is a Lenovo bug.

To summarise this for everyone to save grappling through a long thread...
To summarise this for everyone to save grappling through a long thread...

This is a bug with Password Manager part of the Lenovo Client Security
Solution (v. 8.30.0031.00). The solution is:

Click Start and type "password vault"
Click "Password Vault" (listed under Control Panel in the Start Menu)
Click "Set Preferences" in the menu
Under the General tab, uncheck "Enable hot keys"
Click OK
Close Password Vault
Log off (or reboot) and log back in

Watch out for an update to the Client Security Solution application from
Lenovo in the future if you would like to use hot keys.

Thanks for bringing this solution to our attention.

--
Terry Farrell - MSWord MVP


Submitted via EggHeadCafe - Software Developer Portal of Choice
High Precision Interval Timer
http://www.eggheadcafe.com/tutorial...6-b5a707b41027/high-precision-interval-t.aspx
 
Ad

Advertisements

M

Mostafa

I had this problem, I found that the problem with my 2010 word and win7 is depend on thinkpad client security software and after I install office 2007 patch of this software my problem is solved.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top