Office 2007 Compatibility Question + Pre-release beta error


R

rx213b

I have been tasked with migrating my organisation from Office 2003 SP3 to
Office 2007. We have a number of configurations, but one is causing me some
headaches.

Currently our configurations are as follows:
Config 1:
Outlook 2003 SP3
Word/Excel/Powerpoint/Access Snapshot 2003 viewers
Office 2007 Compatibility Pack v12.0.4518.1014 (this is up to date with
security patches)
Config 2:
Outlook 2003 SP3
Office Standard 2003 SP3
Access Snapshot Viewer 2003
No compatibility pack
Config 3:
Full Office Pro 2003 SP3 suite

Now my issue is config 1. To open word documents with the latest Word viewer
it needs the compatibility pack, however I can't find any literature on
whether this is actually compatible.
I am currently receiving an error in Outlook after fully upgrading to Office
2007 SP1, the error reads - "This file was created in a pre-release version
of outlook 2007. outlook will convert it to the most recent version of the
outlook 2007 file format when you save the file. Before opening this file,
verify that it is from a trusted source." There is no add-ins installed and
this error appears every time outlook is loaded and an email is opened.
This led me to believe it somehow is thinking I have a pre-beta release
version of office somewhere which is causing the error. The error seems to
disappear when using a user who has no group policies applied as well, so it
MAY be group policy related.

Is there something I should be looking at in group policy? Or is the
compatibility pack not compatible with office 2007? There has to be someone
who has attempted the same type of config, considering it would be needed
elsewhere in enterprise environments.

Thanks in advance,
Tim
 
Ad

Advertisements

R

Roady [MVP]

Where are you getting this error?
What is the dialog labeled?
Did you ever had a BETA installed on this system before?

Are you perhaps opening an attachment when this happens or do you also have
OneNote installed?

There is no need to leave the compatibility pack installed. Uninstall it
just as Office 2003 before installing Office 2007.
I'd also recommend to recreate your mail profile after the upgrade;
http://www.howto-outlook.com/faq/newprofile.htm
 
R

rx213b

The error appears when you first load outlook, as it opens the first email.
It appears as though it somehow is opening it with a pre-RTM version of
Office 2007.
This error is on a pc that was built up from our standard SOE config, as per
the first config in my original post. We need to keep them this way for
future use as well, so I will need an answer regarding the compatibility
pack's interaction with Office 2007 itself.
No beta products were installed, the version of the original compatibility
pack was given in the original post.
As per your request about the profile, I've recreated it however there was
no difference. This error is re-producible as well, by removing the user
profile or email profile.

Thanks,
Tim
 
R

Roady [MVP]

The Office 2007 Compatibility Pack in not needed when you have Office 2007
itself installed.
Which group policies do you have set?
Do these apply to Office 2007 or a previous version of Office?
Which mail account type are you using?
Do you perhaps have any pst-files connected as well?
 
R

rx213b

Sorry if I didn't explain myself clearer in the first post. We have some
areas of our business which do not need to edit Office documents (such as
word/excel/powerpoint), so we load the office document viewers on with just
Outlook.
As far as I have found so far, there is no true 2007 version of the word
viewer. It is a 2003 viewer (and denotes that by the version number
11.8212.8221 instead of being 12.x.x). This means the compatibility pack must
be installed for it to be able to open .docx files.
The error appears after fully creating a clean exchange profile with no pst
files, putting the user information in then loading an email. It doesn't seem
to make a difference whether the profile is setup with cached mode or non
cached, the error still appears.
I've just had a look at our sandbox group policy section and some 2003 group
policies are still applying, the group policies we have set are mostly to do
with macro security, automatic update and the workgroup template areas.
On top of this I've fully recreated the group policies for Office 2007
locally but it will still be applying the 2003 ones.

Could you confirm whether or not the compatibility pack could be causing
this error? Or whether it's something else?
 
Ad

Advertisements

R

rx213b

Still looking for an answer regarding this...
Can the Office 2003 viewers & compatibility pack coexist with an install of
Outlook 2007?

Also at the moment working through removing all possible updates/patches
from the office system to try and isolate the problem but not having any luck.
This doesn't seem to be documented anywhere, is this unique to the method of
upgrading that we're using where you import the old profile and convert it?

Look forward to a response.
Tim
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top