Pasting from the clipboard


Joined
Feb 4, 2015
Messages
16
Reaction score
1
When I use the “Paste All” button on the clipboard manager, all the text is pasted without a style as Times New Roman 12. I have to go to all paragraphs and manually apply the Normal style, which is Calibri 12.

However, if I manually click each clipboard item the text is inserted with the Normal style. No cleanup is necessary.

Is there a way to fix the “Paste All” button so it inserts text with the proper style?

My Cut, Copy and Paste options are set as follows:

Paste within same document Keep source formatting
Paste between documents Merge formatting
Paste between docs with conflicting styles Keep source formatting
Pasting from other documents Merge formatting
 
Ad

Advertisements

Ad

Advertisements

macropod

Microsoft MVP
Joined
Mar 2, 2012
Messages
522
Reaction score
48
So, the paste condtions are controlled by the last-listed option above (which you mis-named):
Pasting from other programs > Merge formatting
If you want to force the pasted content to apply the destination Style, change that to 'keep text only' and, if you want it to adopt the Normal Style, paste into a range using that Style. Note that this will also strip out any non-text elements. Alternatively, to preserve font attributes such as bold & italic, plus non-text elements, continue using the Merge formatting option - or use the 'keep source formatting' option - and select all of what you've pasted and re-format it in one go. There is no need to reformat paragraph-by-paragraph.

For more info, see:
https://blogs.office.com/2012/02/10/tip-how-to-cut-and-paste-without-messing-up-formatting/
https://support.office.com/en-us/ar...ste-text-20156A41-520E-48A6-8680-FB9CE15BF3D6
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top