read only


F

ferrium

When trying to publish to the FTP I am being told by publisher that it is a
read only file. What do I do?
 
Ad

Advertisements

T

TopherFox

I am seeing dozens of people with this publishing problem wherein it says
that the destination is "read only". But no one has ever given a real answer.
It has nothing to do with permissions on the host, because I can send the
files using any other FTP program just fine. I tried having publisher not
make a sub-folder, no change. Looking on the web, it appears to be a huge
issue for MANY MANY publisher users. Has anyone ever REALLY explained or
solved this problem? Is it just some mysery that no one has figured out? We
need a hero on this one!

David Bartosik said:
Ask you host to modify permission on the site folder.
--
David Bartosik - [MSFT MVP]
http://www.davidbartosik.com


ferrium said:
When trying to publish to the FTP I am being told by publisher that it is a
read only file. What do I do?
 
D

DavidF

As no one else has taken a stab at this, I looked back through other
postings about a "read only" error. First of all, it is far from MANY, and
it is not HUGE as you assert. But, I agree that in at least some cases it
appears that it is not a "permissions" issue.

While reading the relatively few posts about this problem I ran across a
thread where Rob had proposed that this problem is caused by
corrupted/broken FrontPage server extensions, which happens if you use a FTP
program to upload your site as you did. Use FTP or HTTP...not both. Perhaps
you can be your own hero, and help everyone else that has this problem, if
you test this out and report back.

First test to confirm that the FPSE are installed. Browse to a hidden web
page called "_vti_inf.html" on your domain, or as an example:
http://www.yourdomainname.com/_vti_inf.html You should get a confirmation
page. If you don't then you need to install them. However, its possible to
get this page and still have corrupted FPSE, so if you get the confirmation
page, contact the administrators of your site and tell them that you think
the FPSE have been corrupted by you FTPing to the site, and need to be
reinstalled.

After you are sure the FPSE have been installed correctly, delete all the
files off your host, and try your HTTP uploading again.
http://msmvps.com/blogs/dbartosik/articles/80557.aspx

Do you get the same error? If you do, then please post exactly each step you
are taking to publish/upload your page and be specific. And if you do solve
the problem, then post back those steps, so they can be shared with others.

DavidF

TopherFox said:
I am seeing dozens of people with this publishing problem wherein it says
that the destination is "read only". But no one has ever given a real
answer.
It has nothing to do with permissions on the host, because I can send the
files using any other FTP program just fine. I tried having publisher not
make a sub-folder, no change. Looking on the web, it appears to be a huge
issue for MANY MANY publisher users. Has anyone ever REALLY explained or
solved this problem? Is it just some mysery that no one has figured out?
We
need a hero on this one!

David Bartosik said:
Ask you host to modify permission on the site folder.
--
David Bartosik - [MSFT MVP]
http://www.davidbartosik.com


ferrium said:
When trying to publish to the FTP I am being told by publisher that it
is a
read only file. What do I do?
 
L

Ladalang

In an FTP environment FPSE is disabled so telling him to check he has it
installed is false. He won't be able to. You can't use FPSE in FTP. And
using a third party ftp client creates problems saving the pub file as an
index.html file it adds rich html and distorts and ruins the images. You
have to publish ftp from the document. I called the host company and asked
them to refresh the web space, we have to wait an hour before we republish
but we will see. The file isn't read only.
 
D

DavidF

Not sure what post you are replying to, but part of your answer is
incorrect. If you Save as a Web page in Pub 2003, then yes, you end up with
"rich html", but you should be using Publish to the web which produces
filtered code, and you can direct that code to your local computer and then
use a FTP client to upload to the server. That does not ruin images...if you
have problems with images, it is because of other reasons. You do not
publish using ftp directly from Publisher documents since IE7 was
introduced.

If you want further clarification, please post back...

DavidF
 
Ad

Advertisements

R

Rob Giordano [MS MVP]

in addition to what David says...ftp does not disable FPSE it just usually
breaks them if installed.
and you can still check to see if they are installed, and you can have the
host run a health check on them.

dunno why I responded to this partial thread anyway.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top