Special Effect is unavailable for Command buttons

Discussion in 'Access General' started by Ron Weaver, Mar 27, 2006.

  1. Ron Weaver

    Ron Weaver Guest

    For some reason I am not able to use "special effect" on command buttons. It
    is set to flat. I would like them raised. It works on combo and text boxes.
    Any ideas?
     
    Ron Weaver, Mar 27, 2006
    #1
    1. Advertisements

  2. Ron Weaver

    Brian Guest

    That's not a property of a command button. However, if you really need it, do
    this:

    Create a text box.
    Format it as you like
    Give it a default value
    Give it a top margin & center the text so that the default value appears
    centered
    Lock it
    Disable it

    Create a button on top of the text box.
    Make the button Transparent.
    Put your event on the button's Click event.

    Now it looks like you have a sunken or etched button (but why bother?)
     
    Brian, Mar 27, 2006
    #2
    1. Advertisements

  3. Ron Weaver

    Ron Weaver Guest

    Brian

    Are command buttons supposed to flat? I just pulled up the Microsoft sample
    database "Order Entry", and all of the command buttons are raised. In Excel
    they are raised also.
     
    Ron Weaver, Mar 27, 2006
    #3
  4. Ron Weaver

    Brian Guest

    Oh, sorry. I was so focused on the ability to change the special effect that
    I missed your underlying question.

    There is a way to change default format for each object type, but (at least
    with Access 2003 that I am using), I do not see Special Effects as a
    configurable option for buttons.

    What happens if you copy the button from the sample database and paste it
    into your database? Does it paste correctly, or does it assume the flat
    effect? If it is correct, you might be able to change the default by doing
    this:

    Go to design view
    Click the correctly-formatted button
    Cick Format -> Set Control Defaults to get the default settings to match it.
     
    Brian, Mar 27, 2006
    #4
  5. Ron Weaver

    Ron Weaver Guest

    I just Copied the raised control to my Access 2003 and it pasted flat. I
    think that is really wild. If you hear anything on this, please let me know.
    Thanks
    Ron
     
    Ron Weaver, Mar 27, 2006
    #5
  6. Ron Weaver

    Brian Guest

    I've never seen this, but perhaps one of the MVP's has. Try the reverse, just
    for the sake of interest. Does your flat one paste raised into the sample DB?
    Also, are new buttons raised if you create a new blank DB and then create a
    form & button there?

    If either of these is true, then it must be one of the DB-specific options,
    and I have not explored these entirely. Tools -> Options has some formatting
    options such as Forms/Reports -> Use Windows Themed Controls on Forms. I
    don't see anything in there for
     
    Brian, Mar 27, 2006
    #6
  7. Ron Weaver

    Ron Weaver Guest

    Brian
    My flat command button came out raised in the other database form. A new
    database in my access 2003 resulted in the same flat button. I can't find
    anything in ->Tools>Options>Formatting. I have looked in Microsoft help and
     
    Ron Weaver, Mar 27, 2006
    #7
  8. Ron Weaver

    Brian Guest

    Sorry I wasn't much help. One more thing I would try, just to see if it sheds
    some light: copy an entire form from the sample db and see how the buttons
    fare when the form is pasted into your DB in its entirety. No answer there,
    I'm afraid, but if this works, it will at least tell us that the issue is at
    the form level instead of the DB level.
     
    Brian, Mar 27, 2006
    #8
  9. Ron Weaver

    Ron Weaver Guest

    I imported the form. The Buttons are still flat with no formatting available.
    I have been all over Microsoft's site with no results??
    Thanks for trying.
     
    Ron Weaver, Mar 27, 2006
    #9
  10. Ron Weaver

    Ron Weaver Guest

    Hey Brian

    If you are still watching this:
    All of the buttons in my database were raised when I went into it this AM.
    This afternoon they are back to FLAT?????
     
    Ron Weaver, Mar 29, 2006
    #10
  11. Ron Weaver

    Ron2005 Guest

    Since the problem is obviously beyond logic

    Have you tried a compact and repair?
     
    Ron2005, Mar 30, 2006
    #11
  12. Ron Weaver

    Ron Weaver Guest

    Yes, I even reinstalled Access 2003. It's strange how I can pull up the older
    Access 97 programs converted to Access 2000 and they are just fine. There is
    no formatting available, it's just the default.
     
    Ron Weaver, Mar 30, 2006
    #12
  13. Ron Weaver

    Ron2005 Guest

    And if opened from a different machine? (both AM and PM)
     
    Ron2005, Mar 30, 2006
    #13
  14. Ron Weaver

    Ron Weaver Guest

    Yes, it may work if ran on another computer. I also had a "sunken" dialog
    box that went back to "flat", but I finally got it back to "sunken" after
    changing the format to "shadowed" then back to "sunken" a couple of times.
    Crazy!
     
    Ron Weaver, Mar 30, 2006
    #14
  15. Ron Weaver

    Ron2005 Guest

    If that is true then it would seem to imply that it is your computer -
    somewhere in the gigabytes of data in hidden control files and settings
    somewhere.

    On my home computer something happened to it and it would only allow me
    to dial out once per boot. After the first dialout it would simply hang
    in the dialout process. Dell and MS could never figure out what it was
    - even after re-installing multiple things. Final answer was wipe the
    drive and start over.

    Everything so far as sort of indicated that it is your computer (if it
    truely works properly on a different computer,) and I think you know
    what that means.

    I have no more ideas, myself. Good luck

    Ron
     
    Ron2005, Mar 30, 2006
    #15
  16. Ron Weaver

    Ron Weaver Guest

    Thanks for your input.

    Ron
     
    Ron Weaver, Apr 1, 2006
    #16
  17. Ron Weaver

    Ron Weaver Guest

    I FOUND THE ANSWER!!

    Through Google in a Microsoft forum, someone asked the same question
    concerning flat buttons and Access 2003. This was the answer:
    Yes, this is normal, but you can change it if you want. Select 'Options'
    from the 'Tools' menu, select the 'Forms/Reports' tab, and un-check the
    option 'Use Windows Themed Controls on Forms'.
    That did it.
     
    Ron Weaver, Apr 1, 2006
    #17
  18. Ron Weaver

    Seth Garrett

    Joined:
    May 16, 2014
    Messages:
    1
    Likes Received:
    0
    I'm using Access 2010 and I am having the same problem...and unfortunately unchecking the setting 'Use Windows Themed Controls on Forms' doesn't help...any ideas?
     
    Seth Garrett, May 16, 2014
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.