There is no object in this control


R

Ray

My Access 2003 application was working for years. I then received "There is
no object in this control" when I opened one of my forms. The form references
a control in mscomctl.ocx. The control that it did not like was the TreeView
control.

I tried to re-insert control in the form and got the error "The OLE Server
isn't registered". After re-registering MSCOMCTL.OCX (originally getting a
0x8002801c error but corrected that error after installing Vista SP2), I
still get "There is no object in this control" when I open the same form.

I followed up on the Visual Basic 6.0 Service Pack 6 Runtime Extended files
update related to Security Update 960715 and installed the update. The update
is suppose to correct a security issues with many controls including those in
MSCOMCTL.OCX. No change, I still get the error.

I researched the KillBit issue described in The Kill-Bit FAQ which is
suppose to prevent certain controls from running in IE and "Microsoft Office
scenarios" (?). I find valid Pheonix-Bit entries in my registry
(HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Internet Explorer\ActiveX
Compatibility\{...} corresponding to the "killed" TreeView control.

I ran RegCure, Driver Detective, Spyware Doctor and Registry Mechanic and
everything is clean and up to date. I still get the message "There is no
object in this control" when opening the form.

Anyone have any suggestions on what else I could try?
 
Ad

Advertisements

Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top