Visio for Enterprise Architects doesn't show "Generate" option on Database menu


I

Iván Torres

As far as I've read everywhere this option should be available. I have
Visual Studio 2003 for Enterprise Architects which includes Visio 10.0.2075
(later updates take it to 10.0.6871)

I have just re-installed VS and Visio in case there was some installation
problem, but the option is still not available. I don't know if the option
is available depending on the template in use, but I have tried with an ER
Source Model template and an ORM Source Model.

Should the option always be visible?

Any ideas about what is wrong?

Thanks for the help.
 
Ad

Advertisements

B

Barb Way

The Generate option is only available from the Database Modeling solution
(New > Database > Database Model Diagram).
You can create ER Source Models which are built into a Database Model
project, and generate from those.
Also, I believe you can create ORM Source Models and use them similarly.
But the Database Model Diagram is the only one with the Generate capability.

For reference, you may want to check out some of the DB model diagrams
(http://office.microsoft.com/en-us/visio/CH010266611033.aspx).
I also suggest you review the older topics on MSDN, particularly the
information on "Mapping an ORM Model to a Logical Database Model" :
http://msdn.microsoft.com/en-us/library/aa290380.aspx

In general, you will create a Database Model diagram, then create or import
to it ER or ORM source models, or do design work directly within it, or
Reverse Engineer from an existing db server, then pull the parts together
and Build a Project, which you can then Generate to a SQL Server or other
DB type.


Barb Way
Product Support - Visio
Microsoft Corporation
[This posting is provided "As Is" with no warranties, and confers no
rights.]
--------------------
From: "Iván Torres" <[email protected]>
Subject: Visio for Enterprise Architects doesn't show "Generate" option on
Database menu


As far as I've read everywhere this option should be available. I have
Visual Studio 2003 for Enterprise Architects which includes Visio 10.0.2075
(later updates take it to 10.0.6871)

I have just re-installed VS and Visio in case there was some installation
problem, but the option is still not available. I don't know if the option
is available depending on the template in use, but I have tried with an ER
Source Model template and an ORM Source Model.

Should the option always be visible?

Any ideas about what is wrong?

Thanks for the help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top