FireFox browser will not open publisher web page


Mike Koewler

You aren't kidding - I got one little graphic but the code is 1000s of
lines and the page looks to be a few thousand pixels.





I was surprised when I found out that FireFox does not open my web page that
was built using piblisher 2003.

Rob Giordano \(Crash\)

What's the URL.
FF should open it, it may not look very good, but it should open it.


Rob Giordano
Microsoft MVP - FrontPage

|I was surprised when I found out that FireFox does not open my web page
| was built using piblisher 2003.




As Rob said, most Publisher sites can be tweaked to work in FF. You are
doing a number of things that are creating problems in IE, let alone in FF.
One of the things about IE is it will load just about anything you throw at
it, and you are making some basic design mistakes on your home page...your
index.htm page.

On your index.htm page you seem to be inserting an oversized image of
lightning...and actually trying to crop an image of a city with lightning: . So the first thing
to do is if you want to use only a portion of an image, then crop the image
in a third party image editing program before you insert it. Don't try to
crop it in Publisher...that only works for print documents. It doesn't
actually crop the only hides the portion that you try to crop,
as the link above shows you. If you don't have an image editing program,
then download and use . And while you are cropping the
image, resize the image to the width you want to use on your web page, and
96 dpi.

Once you have your image ready, don't put it on a master page. You may also
find that it isn't going to work as a background image either. In fact the
major problem with your home page probably is in how you are using the
lightning image.

Then go to Tools > Options > Web tab and uncheck "Rely on VML..." and "Allow

Run the design checker tool.

Do a web page preview in IE.

Then compress your other images: Compress graphics file sizes to create
smaller Publisher Web pages:

Now when things seem ok in IE, and you are ready to produce your web pages,
go to File > Publish to the Web, not "Save As a web page".

But before you upload your new files, when you "Publish to the Web", direct
your web output to a folder on your computer where you can find it, instead
of your web host. Download and install FireFox and watch as you do, so that
you don't make it your default browser. With FF installed open it, and File
Open File and browse to the folder on your hard drive where you directed
your Publisher web pages. Open the index.htm file and see if it loads ok in

If the index.htm file doesn't load correctly, then try dragging the
lightning image off your Publisher page into the scratch area, and "Publish
to the Web" to your test folder again. Again try opening it in FF. I suspect
that you aren't going to be able to insert one large image (your lightning
image) and then layer on your text and hyperlinks and expect it to work
correctly. But at least this gives you a method to test the design approach.
Its a cool picture, but you might have to do something else for a

Log onto your site and use what ever control panel you are given to delete
the old index.htm file and index_files folder before you upload again. The
Publish to the Web and upload your new files.

Take those steps, and post back with any remaining issues with your site
loading in IE or FF. Please be specific and provide the URL.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question