OWC11 not working with 64-bit vista



Does OWC11 works with 64-bit versions; I have a .net desktop application
which works fine in all 32-bit versions except 64-bit vista & windows 7; I
tried compiling the entire application in vista 64-bit machine by selecting
the target platform as 64-bit but no luck and getting the error "Class not
registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))" I
tried installing the OWC11 from the microsoft website couple of times and
everytime it says success but no luck with the 64-bit systems.

Anyone has any OWC 11 solution for the 64-bit systems?


Its working fine, here is the solution

- Install the OWC 11 (Office Interops if required)
- Open the .net solution in Visual Studio, change the Target Platform to "x86"
- Compile & Deploy

Patrice Dargenton

Hello, do you mean that OWC works with 64-bit version of Windows ? Are you
sure ?
Your solution is to install Visual Studio on the 64-bit Windows ?

In the MSDN doc, it is said that OWC is not available for 64-bit platform:
"Office Web Components is not supported on 64-bit operating systems."

How can you register the 32-bit ActiveX OWC on the 64 registry ?
Are you sure this is not WOW64, a 32-bit virtualising solution ?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question