Apple Script in Outlook 365 Mac keystrokes blocked on M1 mac


Joined
Sep 16, 2017
Messages
8
Reaction score
0
I just switched to an M1 Mac (OS12.3.1) and scripts that worked fine under the Intel Mac (12.3.1) stopped working

… is not allowed to send keystrokes.
System Events got an error: XYZ is not allowed to send keystrokes. (1002)


Now I went to all the known steps to give permission in the Privacy panel (I allowed Accessibility, full disk access and files and folders). I also allowed Script Editor permission.

Looked in the Internet but found nothing (most post are old and/or not for M1Mac).

And I still get this annoying box. Any solutions?

Here is the script.


tell application "Microsoft Outlook" to activate



delay
2



Code:
tell application "System Events"

tell application process "Microsoft Outlook"

set frontmost to true

repeat until frontmost

delay 0.1

end repeat

end tell

delay 0.1

keystroke character id 107 using {control down, command down}

end tell

 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top