excel found unreadable content' error is coming while opening xlsx file


Joined
May 23, 2015
Messages
1
Reaction score
0
I have an application which exports data into .xlsx format. The excel file of format .xlsx is created through OpenXML. While trying to open it it gives error "Excel found unreadable content in (filename). Do you want to recover the contents of this workbook? if you trust the source of this workbook, click Yes." On click of yes file opens with another message giving log file of the repair. Once its opened, I save the file under some other name and now if I try to open the second file, it opens fine.
This only happens with Office 2010, with MS office 2007 its works fine. I even tried to create a small application (just to be sure is not related to my code) exactly same as in this link small application link . The issue remained same I was able to open the excel file fine in 2007 but in MS office 2010 it gave same error. I googled a lot but no answer. I cant change the file to resolve the issue once its created. I only need to make changes in the code to solve the issue. Please help
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top